About YouTube "Building with VPS: Getting Started with Lightship"

I watched YouTube “Building with VPS: Getting Started with Lightship” and ran the script. But, the plane is detected, but the “anchor” is not displayed when I tap the screen.
Please tell me what happens when I run “ARGameLogic.cs”.

Hi Noriko,

Please provide the information below:

  1. Device Type -
  2. ARDK version -
  3. Unity version -
  4. Host machine -

Thank you for contacting us.

  • Problem category : semantic segmentation
  • Device type and OS version : iphone11 pro / iOS 15.5
  • Host machine and OS version : macOS Monterey version 12.4
  • Issue Environment : Unity Mock / on device
  • Xcode version :13.4
  • ARDK version :2.0.0
  • Unity version : 2020.3.35f1



Please provide a screenshot of your Inspector view. There is a good chance you didn’t assign a property and this would be the reason the anchor is not appearing.

ARGameLogic.cs is a script used to assign different events to our action. Make sure you assign the ARNetworkingSceneManager to the Manager property under AR Game Logic Script in Inspector view.

For more information take a look at Shared AR Session & Plane Tracking Video Tutorial and ARGameLogic.cs script issue from the community forums.

Attached is a screenshot of the inspector view.



There is a duplicate ARNetworkingManager. Open your script and delete the one you don’t need if you haven’t done so already. Your Inspector view looks correct.

Also, did you make sure to add using System; and using System.Linq; to your script header for ARGameLogic.cs? It appears you used the GameObject mushroom, try using a cube prefab for testing instead. Let me know if this resolves your issue.

Thank you for your reply.
“ARNetworkingManager is a duplicate. Please open the script and remove the ones you don’t need if you haven’t already.”
Where does this statement indicate?

What part of “ARNetwirkingSceneManager” or “ARGameLogic.cs” is it referring to?
Any clarification would be appreciated.


In the previous message there was an error stating a duplicate, but it appears to be disregarded already.

As for ARGameLogic.cs: session.Ran += OnSessionRan is causing an issue because OnSessionRan is an empty function.

Try the solution below:

  1. Change session.Ran += OnSessionRan

  2. To session.Ran += OnSessionStarted

  3. Remove the additional session.Ran += OnSessionStarted line or change it to

session.Ran -= OnSessionStarted.

1 Like

Hi Moranda
Thanks for the reply.

I solved the problem by trying the solution.

1.session.Ran += OnSessionRan
2. session.Ran += OnSessionStarted
to Change.

Thank you very much for your kind help.

This topic was automatically closed 2 hours after the last reply. New replies are no longer allowed.

You’re welcome!

1 Like