Adding AR Objects To Private Mesh in Unity and viewing it in RL

Description of the issue:


I’ve been able to successfully import a Private Mesh that I scanned in Wayfarer App into Unity and place objects relative to that mesh, however, how do I now view those objects in real life?

I tried using the ‘Wayspot Anchors’ template, but I get stuck trying to save the mesh and objects so that the app would localize in real life and display the 3D model. Is this even possible?

The idea is to be able to experiment with my own 3D models and private meshes (think an AR cubby house in the kids’ room).

Any help would be appreciated.

Hello Milé,

Using Wayspot Anchors, you can view your placed virtual objects in the real life environment. Wayspot anchors allow you to precisely locate AR content in the real world relative to a VPS-activated Wayspot or Private VPS Location. Please refer to this link for more information.

Can you please provide any error messages you are getting while trying to save the mesh and objects?

Hi Umaiya,

Thank you for your response. There isn’t a specific error I am experiencing, but to elaborate more on my question:

  • Once I am able to localise based on my private mesh, and place a red cube (min 20:55 - Start Building with Lightship VPS | Lightship Summit 2022 - YouTube), and then I ‘save’ that cube, the cube loads easily if I restart the app.

  • Is there a way to move the cube around in the location I want? If not, how do I go about placing the cube in the exact location I want and have it persist?

  • I tried the below:
    1.1 Loaded the private Draco mesh in Unity
    1.2 Placed the cube where I want
    1.3 Deleted the mesh
    1.4 Saved the GameObject as a prefab and replaced the red cube
    1.5 Built the app
    1.6 The location of the cube now is where I placed it in Unity, however, it is relative to where I click. I don’t know where exactly I need to click to make it appear in the exact location I want

Or can I load the saved cube in Unity so that I can move it around. But then the issue from point 1.6 would persist.

I’ve been referring to the tutorial in your link, however, it looks like the WayspotAnchorController (which looked like a potential solution) is a little different from what is already in the Unity templates and I am unable to get it working.

Apologies, I am more of a 3D model designer than a software engineer.

Thank you

Hello Milé,

Thanks for sharing your requirements in detail.

The answer to your question is, that when you are trying to place virtual content in the real world, please add ARAnchor instances and attach your content to them. This helps your content’s position remain stable, even as the AR session updates its understanding of the environment over time.

Please refer to this use case for more details.

I hope this helps!