Android cannot build - A failure occurred while executing$ActionFacade

Issue Category - Android ARDK build - of ARDK Sample Applications

Device: Android - Pixel 5
Host Machine - Occurs when tried with either Windows 11 or Windows 10
ARDK - Version 2.2.1
Unity - Error occurs with either: Unity 2020.3.40f1, 2020.3.15f2, or 2021.3.10f1
- all with default Unity installations of Android Build Support

          NOTE: Error messages and configurations shown below are from Unity 2020.3.40f1

Description of Issue:

Android build is terminated with terminated with message:

A failure occurred while executing$ActionFacade
                          See the Console for details

I get this termination message testing two different Lightship tutorial projects:
           - PongHLAPIDemo, Unity versions 2020.3.40f1 and 2021.3.10f1 - on a Windows 10 PC
           - Lightship Ball Demo - Unity 2020.3.15f2 - on a different Windows 11 PC

 NOTE: I can build and deploy a simple, non-ARDK based Android app to the phone - with no problems.

I have followed the [Building ARDK Apps for Android instructions]( - and have tried specifying the following combinations in Player Settings:

  Minimum API level: 7.1 'Nougat' (API level 25) - Target API - Automatic (highest installed)

Minimum API level: 7.0 ‘Nougat’ (API level 24) - Target API - Android 10.0 (API level 29)

Player Settings -

Console error messages include:

A) > Configure project :launcher
WARNING: The option setting ‘android.enableR8=false’ is deprecated.
It will be removed in version 5.0 of the Android Gradle plugin.
You will no longer be able to disable R8

B) FAILURE: Build failed with an exception.

  • What went wrong:
    Execution failed for task ‘:launcher:processReleaseResources’.

A failure occurred while executing$ActionFacade
Android resource linking failed
C:\Users\markf.gradle\caches\transforms-2\files-2.1\3d1b13a857e40c43266a99844bd8d18d\nar-dependencies\AndroidManifest.xml:28:9-30:40: AAPT: error: unexpected element found in .

 C:\Users\markf\.gradle\caches\transforms-2\files-2.1\3d1b13a857e40c43266a99844bd8d18d\nar-dependencies\AndroidManifest.xml:28:9-30:40: AAPT: error: unexpected element <uses-native-library> found in <manifest><application>.

C) CommandInvokationFailure: Gradle build failed.
C:\Program Files\Unity\Hub\Editor\2020.3.40f1\Editor\Data\PlaybackEngines\AndroidPlayer\OpenJDK\bin\java.exe -classpath “C:\Program Files\Unity\Hub\Editor\2020.3.40f1\Editor\Data\PlaybackEngines\AndroidPlayer\Tools\gradle\lib\gradle-launcher-6.1.1.jar” org.gradle.launcher.GradleMain “-Dorg.gradle.jvmargs=-Xmx4096m” “assembleRelease”

Any help/suggestions would be most welcomed!

Hi Mark,

I see that you tried our article regarding ARDK for Android. Did you happen to also check out the bit about Android 31 and OpenCL?

I replicated this exact issue you’re having and the same error messages and following that bit of our article fixed it. Just make sure you’re also installing a Gradle version that is 6.7.1 or newer. One of our developers used 7.5.1 and I used 6.9 and they both worked fine.

If you’re still having issues, make the highest Android version be 31 rather than auto selecting to force any missing files to be installed

This topic was automatically closed 2 hours after the last reply. New replies are no longer allowed.