ARDK WebGL build error

Include the following details (edit as applicable):

  • Issue category: Unity Example Package
  • Device type & OS version: iPhone 13 Pro on iOS 15.6
  • Host machine & OS version: Mac M2 on Ventura 13.0
  • Issue Environment : Unity
  • Xcode version: 14.0.1
  • ARDK version: 2.5.2
  • Unity version: 2021.3.25f1

Description of the issue:

I’m new to ARDK and Unity.

Following the tutorial “The Basics: Getting Started with Lightship” I created the Lightship Ball Demo AR application using ARDK in Unity: I built the project and it is working on my iOS device perfectly :tada:

I wanted to experiment a WebGL build but the build didn’t work and I got some errors. Here the flow I followed to build with WebGL:

(1) Unity > Build Settings > Select “WebGL” > Switch Platform

(2) Then I got an error message saying: “In order to build a player go to “Player Settings…” to resolve the incompatibility between the Color Space and the current settings”

(3) In Player setting > Other Settings > I got these 2 warnings:

1. Lineage colorspace requires WebGL 2, uncheck ‘Automatic Graphics API’ to remove WebGL 1 API. WARNING: if DXT sRGB is not supported by the browser, texture will be decompressed
2. High quality lightmap encoding requires WebGL 2 only. Uncheck ‘Automatic Graphics API’ if it’s set an remove the WebGL 1 API.

(4) So I did uncheck the “Auto Graphics API” box.

(5) I can now click on “Build”, but finally go these errors:

I’m not sure where to start to fix these problems. Any help or direction about where I should start to fix these issues would be very appreciated. Thank you

Hi Alex,

Unfortunately, Lightship only supports the Android and iOS platforms.

Best Regards,
Maverick L.

Thank you for your reply!

This topic was automatically closed 2 hours after the last reply. New replies are no longer allowed.