Black screen after building

  • Issue category: Finished build; Camera
  • Device type & OS version: Android 11
  • Host machine & OS version: Windows
  • ARDK version: 1.1.0
  • Unity version: 2020.3.25f1

Description of the issue:


After I build and run the finished project on my phone, nothing happens. The camera doesn’t seem to work and it gives me a black screen. I don’t get any errors while building.

Everything worked just fine before I had to re-install Unity (I used Unity version 2021.1.5f1 before switching to the latest stable/recommended version).

At the very beginning, I merely had the issue with the latest AR Services and fixed it with the custom AndroidManifest, which I added to Unity 2020.3.25f1 as well, but it doesn’t seem to work anymore?

Can anyone please help me how I can resolve my issue?

Thanks in advance.

Hi Neetu,

For the black screen issue that you are experiencing on Android, do you see the Vulkan Graphics API listed in your Project Settings > Player > Other Settings > Graphics APIs?
If so, then try to remove the Vulkan Graphics API from your Project Settings, since having this enabled can also cause a blank screen to display on some Android devices.

Remember to add the active scene to the build before building!

Also, there might be camera permission on a device that’s not being allowed at runtime. If you’re building any of the awareness scenes in ARDK-examples, they should have an AndroidPermissionRequestor script component with a Camera element. Maybe check your device’s app permissions, or try deleting the build off your device, rebuilding and redeploying, and see if you get the camera permission pop-up?

Hope this helps!

Hi, thank you for the quick reply!
I’ve checked both, the graphics API and the script component and they were both correctly set.

I just found the issue (it was my own stupidity for not noticing), something went wrong with the MeshChunk prefab while importing the ARDK and the ARMesh wasn’t able to work with my Mesh Prefab, hence the display became all black, but after re-importing everything, it worked.

Thank you so much for your efforts!

Glad that you were able to resolve the issue.