Build of a example scene from the project gives me a black screen

Include the following details (edit as applicable):

  • Issue category: Unity Example Package
  • Device type & OS version: Android
  • Host machine & OS version: Windows
  • Issue Environment : On Device
  • ARDK version: 1.01
  • Unity version: 2020.3.21f1 / 2019.4.21f1

Description of the issue:
Hello, community,
I have imported and set up my projects as per the documentation and the " Getting Started with Niantic Lightship" video. But once I tried out a couple of scenes to build and run on an android device, it runs with a black screen. How should I solve this?

1 Like

The most common things to check on Android

  1. Make sure the camera is set on all the manager/helper objects
  2. Check that you have added the android permission helper script and set it to allow the camera.
  3. In Player settings check the minimum api level is 10 or higher.
  4. In Player settings ensure the scripting backend is set to ilcpp and that the target architecture is set to ARM64
  5. If you are still getting a black screen try setting the blit type to auto under Project Settings->Player->Resolution and Presentation
  6. If all else fails you can download the getting started project file from the dev portal unzip it and open that in unity hub with the add button as this is a project that is already configured.

And remember we currently only support 2019 LTS versions

1 Like

Remember to add the active scene to the build before building!

One more thing to try is to remove the Vulkan Graphics API from your Project Settings, since having this enabled can also cause a blank screen to display on some Android devices. To do so:

  1. Go to Edit > Project Settings…
  2. Select Player, and then look for Other Settings > Graphics APIs
  3. Click on Vulkan, then click on the “-” button

Hope this helps!

Another thing to try.

I noticed that ARDK is not always importing the AR foundation + ARKIT / ARCORE. make sure you have the packages. And that the XR setting is checked in unity.

I was experiencing the same thing, I think it’s because we’re trying to run ARDK on our Windows machines when ARDK’s native plugins are built for iOS, Android, and MacOS, not for Windows OS.

At first I thought maybe I could choose Android as a build target from my Windows PC, but still get the DllNotFoundExceptions type console errors.

Here’s more on the ARDK System Reqs:
https://lightship.dev/docs/system_reqs.html#autotoc_md349

If I enable ARCore from Unity XR Management, I get errors when building: error : colliding-attributes…
In the Getting started sample app, AR Foundation + ARCore & XR Management are not added.

1 Like

Tried all on 2019 LTS and still does not work.
The getting started project works but the Player settings are the same…