Camera showing black screen when unity as library integrated to an android application

Include the following details (edit as applicable):

  • Issue category: Semantic Segmentation / Multiplayer / Real-time Mapping-Depth / ARDK Documentation / Unity Example Package / Sample App aka ‘AR Voyage’ / ARDK Virtual Studio Tools / Developer Tools / Networking / VPS
  • Device type & OS version: Android
  • Host machine & OS version: Windows
  • Issue Environment : On Device
  • ARDK version:1.3.1
  • Unity version:2021.3.2

Description of the issue:

I build a sample object placing in space project using ARDK and its unity builds runs successfully.
But after integrated it with an android app the screen show the unity logo and remains in black screen. Don’t know why this happened but still the unity build working without any issues

I’m guessing you’ve already requested camera permissions within the android app (and verified in OS App settings that camera is allowed)? I don’t generally have a problem with the camera at initial application launch, but I do frequently see the feed go black after an app has lost and regained focus, so there might be something funky with ARDK’s feed re-acquisition flow that shows up in a more complex app but not in a single-purpose start-tracking-on-launch demo?

Naveen,

Would you please provide the device type and version numbers you are using for the following?

  • ARDK
  • Unity environment
  • Workstation
  • Device

ARDK version :- 1.3.1
Unity version :- 2021.3.2
Host machine(OS) :- Windows
Device :- Android /pixel 4a

  • ARDK version :1.3.1
  • Unity version :2021.3.2
  • Device type & OS version : pixel 4a /android
  • Host machine & OS version : Windows

The black screen issue was a known issue with 1.3.1 and has been resolved with the release of ARDK 2.0.0. Please update to the latest version here: https://lightship.dev/account/downloads.