Cannot set framerate in all scripts

Include the following details (edit as applicable):

  • Issue category: Unity
  • Device type & OS version: Android / iOS
  • Host machine & OS version: Mac
  • Issue Environment : On Device
  • Xcode version: latest
  • ARDK version: 1.3.1
  • Unity version: 2021.3.5

Description of the issue:
I have a gamemanager script where I want to set the framerate to 30.
Apparently either in ARVideoFeed or ARRenderingManager it sets the framerate to the ‘recommended frame rate’. There is no proper documentation on how to use this system properly (set fps in own script), so as a work around I just set the values to 30 in both scripts to fix the issue. This is not a proper fix since it will be undone when upgrading ARDK.
It does work when I set the fps after the Start functions have called, which is not helpful.

Please dont set the framerate in an asset file or at least have documentation at the front page on how to set fps, since it is crucial for mobile thermal management

Hi Dylan,

We have a recommended target framerate, but you are able to adjust it. You will have to go into the script to adjust in some cases. I will pass this feedback along to the team. Thanks.

I did find that, but when changing the code of ARDK it will be undone when updating to a newer ARDK.
I would personally like to see either a public/serialized settings in ARRenderManager on the camera where you select the framerate, OR ardk not touching the frame rate at all, leaving it at the Unity default. If there is nothing AR related why you need to change the framerate, why it it being changed at all?

Hi Dylan,

We set the frame rate to match the frame rate of ARKit and ARCore surface native frames.

We are working on enabling the ability to have a customizable frame rate. Please stay up to date with new features and releases on Lightship Platform Roadmap.

1 Like