Connection timeouts for previously working builds, independent of Wifi Network and device

Since yesterday all of our previously working builds of our app, even the Testflight builds, wont work anymore, in that they have connection timeouts/errors upon hosting a session. We did not change anything. We could verify, that the problem occurs independent from the Wifi network and device, by testing it in several networks and on several devices.
In the editor when we ran the scene without a mock environment (“None” in virtual studio), we got the following error message:
IncorrectlyUsedNativeClassException: Native ARDK support is disabled for this platform.

We tried everything from reinstalling ARDK to cloning the project fresh from github, reverting to older states of the project, trying sample projects from ARVoyage, generating a new api key etc… Nothing worked for us.
Other users the Lightship AR Discord Server have the same problem since monday.


  • Issue category: Multiplayer / Networking
  • Device type & OS version: iOS / Other Ex. iPhone 13 Pro on iOS 16.6, iPad Air 5th gen on iPadOs 16.1.1
  • Host machine & OS version: Build from MacBookPro (2021) on MacOS Ventura 13.3
  • Issue Environment : On Device
  • Xcode version: 14.3
  • ARDK version: 2.5.2
  • Unity version: 2022.3.3f1

Bug reproduction steps:
For the error on device: Since it did not work on our project we tried sample projects like “SnowballFight”, which also did not work anymore for us. So just build the SnowballFight exampe to your iOS device and try to host a game using the “host” button in the application. Click all the pop up buttons (“Host Instruction” etc.). Now you should see the “Connecting” UI Hint. After a few seconds a UI Hint pops up showing “Error! Your connection has timed out. Please restart and try again.” and a “Restart” button.

For the in Editor error: In the Virtual Studio select “None” from the options “None”, “Remote”, “Mock”, “Playback”. Switch Unity Platform to iOS. Press play and follow the steps above (as for the device). In the console the following error should appear:
IncorrectlyUsedNativeClassException: Native ARDK support is disabled for this platform.

Are you still experiencing issues with connecting?

Hi Jan,

We had a few other users report this same issue but they have since let us know the issue has been resolved. Are you still experiencing any problems?

Kind Regards,
Maverick L.


I was one of the users, so the issue has also been resolved for me :slight_smile:
I just could not close the issue yet, because the post was marked temporarily as spam.

Kind Regards,