Getting magenta material

Include the following details (edit as applicable):

  • Issue category: Semantic Segmentation / Multiplayer / Real-time Mapping-Depth / ARDK Documentation / Unity Example Package / Sample App aka ‘AR Voyage’ / ARDK Virtual Studio Tools / Developer Tools / Networking / VPS
  • Device type & OS version: Android / iOS / Other Ex. iPhone 8+ on iOS 13
  • Host machine & OS version: Mac / Windows / Linux / Other Ex. Mac on Big Sur x.x
  • Issue Environment : Unity Remote / Unity Mock / On Device / Dev Portal
  • Xcode version:
  • ARDK version:
  • Unity version:

Description of the issue:

i installed the lightship ARDK and it give me on the planefinding a magenta color. i have tried changing the materials but with no luck. any ideas?

ARGameLogic.cs script error from building with VPS tutorial - I’m Stuck - Lightship Community

the question has been solved from the link above.

Hello Kyle,

I was able to reproduce the shader issue found in the PlaneAnchors scene.
To resolve the issue can you try the below options,

Try to create a new Shader, with these settings.

OR try to exclude the shader from DX11 by commenting out line: 25 of the PlanefindingGrid.Shader. The shader can be found in Assets > ARDK > Extensions > Planefinding > PlanefindingGrid.shader.
//#pragma exclude_renderers d3d11.

Hope this helps.

so i went and commented it out but i still get the magenta material. and i cant fix it still.

Hello Kyle,

Could you please try to create a new Shader as I mentioned earlier? Meanwhile please provide some more details,

  1. What hardware/software versions you are using.
  2. Screenshot of your inspector windows.
  3. Screenshot of your Console window in Unity to show the errors you’re seeing
  4. Repro steps to recreate the issue.
    It would greatly help us to troubleshoot the issue.