Getting the Black screen issue when the app launch?

  • Unity version : 2019.4.25f1 LTS
  • ARDK version : 1.0.1
  • Device type & OS version : Android 11 - OnePlus 7T
  • Host machine & OS version : Windows 10
  • Issue Environment : On Device

Description of the issue:
When the app launches I was getting the black screen issue on my mobile device. I am getting the below errors in the Android Logcat, Please check :

2022-01-04 17:03:41.623 30148 4473 Error native E0104 17:03:41.623934 4473 session_c_api.cc:220] operator(): session was passed NULL.
2022-01-04 17:03:41.624 30148 4473 Error native E0104 17:03:41.623998 4473 session_lite_c_api.cc:45] operator(): session was passed NULL.

I have given camera permissions after installing the app and removed Vulkan from Graphic APIs.

Can anyone please help me how I can resolve my issue?

Thanks in advance.

Hello Akhil,

We are tracking similar errors in different areas of ARDK. We are currently working to find a resolution for these issues. We will post here when we have a resolution. Thank you for your patience.

Hello @Jason_Rose1 ,

Any update on this?

Can you please provide the resolution for this black screen issue?

Thanks in advance.

Hello Akhil,

Currently we are still working on an answer for this issue. A fix is in the works. We thank you for your patience. We will post a public response to cover all the instances of this error.

Hi Akhil,

You mentioned that the black screen occurs when the app launches. Are you referring to the ARDK example scenes here? If so, which scenes are you having an issue with?

It might also be helpful if you can attach a screenshot of your build settings, and player settings (other settings) for the project that you’re having issues with that so we can take a look. I’ve attached an example of what we’re looking for here.

Some other common player settings that can cause an issue are:

  • Not setting the target API Level to API Level 29
  • Not using IL2CPP as the scripting backend (Unity defaults to Mono for Android)
  • Not setting the target architecture to ARM64 (Unity defaults to ARMv7 / Mono, instead of IL2CPP / ARM64
Summary

1 Like

Hi David_Quevedo,

I am not referring the ARDK example scenes. I created my own scene in that scene I have added ARSceneManager prefab.

I am attaching a screenshot of my build settings, Please check :

Thank you.

Hi @Jason_Rose1 ,

Any update on this?

I have followed the suggestions mentioned by @David_Quevedo but still, I am getting the same errors.

Can you please provide the resolution for this black screen issue as soon as possible?

Thanks in advance.

Hey @David_Quevedo @Jason_Rose1 thank you for your inputs on the issue so far. We are in the process of building a few demos and unfortunately everything has come to a standstill for us due to the blackscreen issues.

Are there any updates, or temporary fixes/approaches you could suggest for us to continue our work? Or if there is an update on the progress for a fix, that will help us manage expectations, it’ll be really helpful to know more.

Thank you.

Hello Siddharth & Akhil,
We are still working on this issue. If you have any screenshots of this issue that would be most helpful, or any further information, please post your information here. Your patience is appreciated.

Hi @Jason_Rose1,

I am attaching a screenshot of this issue, Please check:

Thank you.

Hello Jason_Rose1 & David_Quevedo,

Any update on this issue?

It will be helpful that you could suggest some temporary fixes/approaches to continue our work.

I am attaching a black screen screenshot, Please check :

Thank you.

Hi Akhil, sorry for the delayed response, but it looks like you’re targeting Android 11 (Api Level 30) in the build settings of the screenshot that you shared previously. Please note that it is possible to target Android 11 with ARDK, but due to changes in that API, you will need to add some tags to the AndroidManifest.xml. More information can be found here under the section “Building for Android 11 (API level 30) and higher.”

One quick test that you can do, though, is to change the Target API Level to Android 10 (API Level 29) and see if you still get a black screen when running the app on-device. Also, you might want to double check permissions for the app on the device that you’re installing to, and enable any permissions that are currently disabled.

1 Like

Hi @David_Quevedo, Thank you so much for your inputs. I have followed your suggestions the black screen issue was solved.

1 Like