I think I'm having trouble importing all of Lightship Hub

  • Issue category: Developer Tools / VPS
  • Device type & OS version: Android
  • Host machine & OS version: Windows 11
  • Issue Environment : Unity
  • ARDK version:2.5.2
  • Unity version: 2021.3.23f1 and 2020.3.2f1

Description of the issue: Help!, I successfully completed the ball tutorial and build the project to my phone. But since moving on I’ve hit various compiler issues. The latest attached. I have tried different unity versions and rebuilt the session. It seems to happen once I import Lightship hub. When I import it, there are a few options greyed out, but is that files that are installed by the ARDK package so aren’t needed?. When I try to open the Object placement template from the welcome menu it doesn’t work. When I open it from the project window it opens but InteriorMockUpScene, directional light and AR Manager are missing.

Re-imported on 202.3.2f1 and here’s a vid of the lightship hub import

and the error that came up previously (which potentially is down to the unity version?) ’ error CS0246: The type or namespace name ‘Codice’ could not be found ’

Hi Richard,

I’m sorry to hear you’re having trouble using Lightship Hub. Have you tried importing everything from Lightship Hub and Lightship into a brand new project? Do you still get the same error messages? Also, with the Codice error message, that is due to an unused import in the Remote Authoring example. If you go to Assets/ARDKExamples/RemoteAuthoring/Editor/LocationManifestManagerEditor.cs and comment out using Codice.CM.Common.Replication you shouldn’t get that error any more.

Maverick L.