Imported private scan mesh does not show up via VPS Authoring Selected Location list

  • Issue category: VPS
  • Device type & OS version: Android 9
  • Host machine & OS version: Windows
  • Issue Environment : Unity Mock
  • ARDK version: 2.5.2
  • Unity version: 2021.3.1f LTS

Description of the issue:

I have trouble import private scan via VPS Authoring because it will not show in the Selected Location list.

I made a private scan 2023-07-11 that was ready for download yesterday 2023-07-11. I downloaded the ready mesh and tried to import it via VPS Authoring, but the import does not show in the Selected Location list.

How could I solve this?

Pontus Jakobsson

Hello Pontus,

Does your mesh not show up in your Downloads folder at all, or only when you’re trying to import it into your project? Did you check that your mesh successfully downloaded?
Could you please verify the steps you took to download your mesh? I went through the following steps and was able to successfully import it:

  1. Go to your Geospatial Browser and click the Download button for the mesh you would like to import.

  2. Select the Import Mesh button in Unity to find your downloaded mesh. If you’re unable to see the button, make sure you go to the bottom of the VPS Authoring panel and scroll to the right.

  3. Select your mesh (as a ZIP file) from your downloads folder and save it in your preferred location.

  4. Once you’ve imported your mesh, you will be able to select it (and any others you import) from the Selected Location dropdown menu.

Please let me know if you’re still having trouble importing your mesh.

I tried it again following the steps you instructed. I believe it was the same as I did before, but now it is working. I am unsure why it did not work before, but in any case thank you for the help!


Pontus Jakobsson