In ARDK 3.0 beta, URP is not supported?

Include the following details (edit as applicable):

  • Issue category: Rendering - URP
  • Device type & OS version: Engine
  • ARDK version: ARDK 3.0 beta
  • Unity version: 21.3.12

Description of the issue:

I downloaded Universal RP and set Graphics setting and Quality setting. But when i import mesh from GSB, the mesh of prefab of location doen’t work properly. It happened when I imported URP. When I was in built-in environment, the meshing prefab worked properly. So What i want to know is, is URP supported in ARDK 3.0 beta? If It is, What should I do to make the location mesh to be rendered properly?


This has always been the case. You have to change the material manually :confused:
Still hoping for better URP support as it’s the way forward

Hello Olivia,

URP is supported in ARDK 3 but if you manually imported URP into a project that was originally not using URP you will run into this issue with pink textures. You have a few options depending on how many meshes you currently have imported and how far you’ve progressed with your project:

  • If this is a fresh project, it might be easier to restart and use the 3D URP template which will do all the UPR setup for you. After you get ARDK set up and your LocationManager created, any imported mesh will come in URP ready.
  • If restarting isn’t an option or you only have a few imported meshes, you can also delete your current imported meshes and Manifests and reimport them (just make sure URP is already active) which will import them URP ready. You’ll just have to drag the manifests back into their respective ARLocation

Otherwise, you would have to do as Dylan described and change materials manually which can be a bit of a process if you have multiple meshes:

  1. Click on the imported mesh
  2. Scroll down to the Material which is at the bottom of the mesh’s inspector
  3. Click on the shader selection box (it should say Standard) and go to Universal Render Pipeline → Lit
  4. Once you do that you want to expand the Material and go down to the Surface Inputs section
  5. Click on the small circle next to Base Map and search for submesh_texture_0 in the search box that appears

If neither of these suggestions worked for you, please submit screenshots of your Graphics and Quality tabs (essentially what Merijn uploaded) so that I can take a look.


It worked. Thanks.

This topic was automatically closed 2 hours after the last reply. New replies are no longer allowed.