Meshing not working properly in ARDK2.3?

Include the following details (edit as applicable):

  • Issue category: Real-time Mapping-Depth
  • Device type & OS version: Android
  • Host machine & OS version: Windows
  • Issue Environment : On Device
  • Xcode version:
  • ARDK version: 2.3
  • Unity version: 2021.3.11f1


I have upgraded my project from ARDK2.0.0 to ARDK2.3.0. I didn’t change anything in the project but the ARDK library, but now, when meshing I get this:

With ARDK 2.0.0 I experience the normal behavior:

ARMeshManager Configuration (I didn’t change anything between versions):

ARDepthManager Configuration (I didn’t change anything between versions):

I guess I am making some stupid mistake, but I don’t know what. Could you help me, please?

Kind regards,



By any chance is this project using networking?

If not, can you confirm that you updated ARDK by deleting the ARDK folder from Assets and then importing the new one?

If so, I would recommend closing Unity, navigate to where your project is in your computer and delete the Library folder and then reopen the project. Test it out and see if that fixes things.

Hi Jesús,

I tried many things, but finally solved it by uninstalling the app from the device before building the new one with ARDK2.3.0. The same issue happened on two different Android devices. One with Android 10 and one with Android 12.

I also have encountered this on android. Meshing stops working randomly and after a few new builds magically works again

I just switched back to ARDK 2.0.1, and experienced the same issue. I first tried deleting the Android/data//cache/UnityShaderCache folder, but it didn’t help. Uninstalling the app before building with the new version worked again.