Mock-Mesh Spawns upside down

Include the following details (edit as applicable):

  • Issue category: ARDK Virtual Studio Tools / Developer Tools
  • Host machine & OS version: Mac M1 Ventura
  • Issue Environment : Unity Mock
  • Xcode version:
  • ARDK version: 2.5.2
  • Unity version: 2021.3.f20

Description of the issue:

As can be seen in the video, my Mock-Meshes always spawn upside down. I did not change anything from the standard settings. Right now I’m using a custom script to turn the mesh after creation, however that is only a work around.

What am I doing wrong?

Is the mock mesh imported from an FBX file? If so, one thing you can try is to enable Bake Axis Conversion on the import settings:

Hi Tobias,

This could be an issue relating to how the model is being imported into Unity. Unity uses a left-handed, Y-up coordinate system which might differ from 3D modeling software using a right-handed or Z-up coordinate system. The mesh data could be misinterpreted by Unity if the data was created by software using a different coordinate system. Other than that, I would try unchecking the ‘Optimize Game Object’ checkbox under the Rig tab of the import settings pane.

I hope that helps!

Kind Regards,
Maverick L.

@Brent_Austin , @Maverick_Liberty , thanks a bunch for your answers. For me the solution was just create a new scene with the ARDK templates. All meshes I used were ARDK provided ones so I don’t really know the issue. But using the Stock templates worked for me.

I’m glad you were able to get the issue resolved!

A bit late but I found the error why it was upside down. The AR Mesh should be -1 on the Y Scale. That was my mistake, as mine is set to simply 1.