Path finding with Lightship

  • Issue category: VPS
  • Device type & OS version: Android
  • Host machine & OS version: Windows

Description of the issue:
Hi, I’ve a logical problem… I saw every tutorial, and I studied the Gameboard in ARDK Example.
Now, I want to make a path finding from the camera (the player) and an anchor, but in this example there is a real-time meshing. How can I use the scan I made to make the path? I don’t understand it… I saw that you used the real-time meshing and tiles to move the yeti from a position to another position.

I hope you can help me… thanks!

Hi Stefano,

I’ll be looking into this issue for you. I will get back to you once I have additional information for you.

Hi Stefano,

I have some lingering questions that came up while I was looking for a potential solution for you. What is the purpose of creating a path from the player to an anchor using the scan of an area? Are you attempting to do this for testing purposes or are you trying to create a single preloaded path that doesn’t depend on real time meshing? Or are you trying to translate the navigation that is going on in the Gameboard into something you can use with Unity’s built in path finding?

Hi Jesus,
I want to make a way finding inside house, making a path visible to the player.
I mean, if I select an anchor (like bathroom), the app had to make a scan to recognize the place where the player is. After it, the app mustn’t make a new scan, but must use the scan alredy made.
So, the path depends on real time scan, but only at the start.

Hi Stefano,

Thanks for clarifying. Now, when you say scan the inside of a house once, do you mean scan the inside once each time the app is open or scan it only the first time the app is in use and all future uses of the app will depend on that scan?

I also saw on your original post that you’ve already made a scan. Do you already have a scan ready or are you referring to a future scan? If so, what did you use (or plan on using) to scan the house?

Hi Jesus,
when I say scan the inside of a house, I mean to scan only at the first the app is in use, so the app scan to recognize and load a scan from memory. For example, I’m in the bathroom, when I start the app, it had to scan and recognize the place, like in the example named “Remote Authoring” in the ARDK Examples. If you select “Relic”, it scans the place and places the Anchors.

I made a scan with the Niantic Wayfarer app, it is all set (scan and anchors).

I want to add a comment to my problem: I want to made multiple scan and then attach them like a single scan to make the entire path of the house (5 minutes are not enough…). Is there any way to make it with Lightship? I search some info, but if you know a way, you help me.

Thanks, btw!

Hi Stefano,

You can try using Sanniverse to see if that meets your scanning needs. It is also available on iPad.

Once you get your scan going, you will want to localize against this location and once localized, align the scan you created to the environment. This can be done with Remote Content Authoring. I saw you had created a topic regarding Remote Content Authoring but deleted it. If you run into any more issues feel free to create a new topic.

Hi Jesus,
For “sanniverse”, did you mean “scanivers”?
I mapped all of the building with niantic, but with two account. The problem, now, is with the API Key that must connected to the account where I made the scans. With Scanverse, I can make scans, but how can I place anchors in them? The panel “VPS Authoring Assistant” can accept only zip where inside there are files of the scan + json for the payload.
So, if I scan with another app, can I use it like a private VPS?

I had the problem with the API Key, I deleted because I found the answer in your docs.

I’m try to using the localization, with your tutorial (link), when I scan the right place, it works fine, same if I try to scan a place not recognized. But after it, if I try to scan the right place, it doesn’t work. I tried to restart the VPS with the Restart() and StopVps(), StartVps(), but still doesn’t work.

Do you know why it doesn’t work?


Hi Stefano,

For the VPS portion what you will want to do is have a Wayspot of something at the location. Once you localize with VPS to that Wayspot, you can overlay your scan over the area. That same Wayspot can also be downloaded and used with our Remote Content Authoring tool. May I also know what you mean when you said that you scanned the location with two accounts?

Lastly, for the VPS issue, can you check the Android Logcat and send any error messages you see to get an idea of the issue you’re running into?