Problem installing ARDK

Include the following details (edit as applicable):

  • Issue category: Unity Setup
  • Device type & OS version: Android
  • Host machine & OS version: Windows
  • Issue Environment : Unity
  • Xcode version: N/A
  • ARDK version: 3.6.0-2406141834
  • Unity version: Unity 2022.3.34f1

Description of the issue:
Using Unity 2022.3.34f1
Targeting Android
ARDK 3.6.0-2406141834

Followed Instructions
Entered my API Key

Go to Niantic Lightship SDK in settings

Editor: SDK diableds,
Android: SDK Disabled

Go to Project Validation in Settings
Get warning inn project validation regarding fixing
enable Niantic LightShip SDK plug-in

Click fix, nothing happens

I have been trying to work with your support.

They aren’t helpful.

Come on guys this is not way to treat devs who just want to make your product great.

Hi Jack,

I wanted to sincerely apologize for the delayed response as we were out of office for the Independence Day holiday. When you tried the Project Validation feature’s “Fix” functionality did you see any errors appear in Unity’s console? If so, please share the errors you’re experiencing here.

Anywho, to get Lightship’s SDK enabled, please follow these instructions: https://lightship.dev/docs/ardk/setup/#configure-your-mobile-platform.

Kind regards,
Maverick L.

Just kept retrying shutting down restarting unity and it worked eventually

This topic was automatically closed 2 hours after the last reply. New replies are no longer allowed.

I’m glad to hear that you got it working! Don’t hesitate to create a new thread or ask in our Discord channel should you need additional support!