Stuck at skybox, Cannot get my app to use device's camera

  • Issue category: Unity Example Package
  • Device type & OS version: Android
  • Host machine & OS version: Windows
  • Issue Environment : On Device
  • ARDK version: 1.0.1
  • Unity version: 2019.4.33f1

Description of the issue:
I am trying to run ARDK examples and have set up my project from the guide and video that was in the documentation and even tired this video where the guy added the scripts to the main camera yet my app shows the solid color view.

What I have tried till now:

Hello Ansh, if the app has been built to device and still shows a black screen for the camera, it’s likely that permissions for the app have not been set. Permissions aren’t auto assigned, and it’s one of the possible troubleshooting steps that is easy to overlook from the community post 467 that you referenced above. Close all open instances of the application on your device, then add permissions for Camera, Location, and Storage to the application. If the rest of the configuration has been set correctly, this should resolve the camera showing a black screen. If the camera is still black, will you please provide screenshots of the Inspector components for the ARScene Camera/ARScene Manager, as well as of the Android Permission Helper script, and the Project Settings > **Player **> Other Settings in your scene? I hope this helps.

1 Like

Thank you so much for taking the time to help Erik, I got it working by using ARDK v1.1.0 and using v1.1.0 of the examples and then followed the steps given in the documentation video.
Thanks again!

This topic was automatically closed 2 hours after the last reply. New replies are no longer allowed.

Fantastic! Lightship will continue to improve, so you may find newer versions resolving future issues as well. Thanks for the update.

1 Like