Suddently VPS is not working when i build in other devices

Include the following details (edit as applicable):

  • Issue category: VPS
  • Device type & OS version: Android
  • Host machine & OS version: Windows
  • Issue Environment : On Device
  • Xcode version:
  • ARDK version: ardk 2.4.2
  • Unity version: 2021.3.12

Description of the issue:

I am making unity ar project using VPS system. But suddently vps is not working when build on other phones except the one i was using continuously. I use build and run the same project for every phone, the only difference (i guess) is just the device.
In those devices, VPS worked properly just before yesterday. From yesterday, vps system is not working properly. Can’t guess any particular reason…


May I know the device where VPS worked on and the devices where it didn’t work? Additionally, for the devices where VPS didn’t work, can you double check in your settings that location is currently enabled for your project?

the working device is Galaxy S9, and devices not working are Galaxy S20, Galaxy folder.
But even on Galaxy S20 and Galaxy folder, it worked correctly until just two days before. Now it’s not working suddenly.
I already double checked that locaton is currently enabled in those phones.


Are you able to provide details on what you’re currently using VPS for? Are you trying to localize to a wayspot, generating a list of nearby wayspots, etc…

Additionally, can you provide a logcat output of the failing devices so that I can look into it and try to see if something that could potentially point to the root of the issue is there? Just make sure you try using your VPS functionality so that it also gets logged.