SyncStateTrackedPeer not working

Include the following details (edit as applicable):

  • Issue category: Multiplayer
  • Device type & OS version: Android
  • Host machine & OS version: Windows
  • Issue Environment : Unity Remote

After attaching the ‘SyncStateTrackedPeer’ prefab, It will not show me the state of all the connected stable tracked peer.

it was supposed to work once I do a simple drag and drop of the ‘SyncStateTrackedPeer’ prefab.

Anyone can guide me where to start debugging? what could be the problem here?

  • Xcode version:
  • ARDK version:
  • Unity version:

Description of the issue:

Hello Peng,

May I know how you’re attempting to run this example? I ran it in both editor and Unity Remote with the same settings you have and in both instances I got the status indicators working. The prefab you’re referring to should not have to be manually added, it will be automatically created when the sample players (Foo and Bar) join.

Foo and Bar was working fine.

All I did was dragged the SyncStateTrackedPeer prefab into the scene and that’s it. I clicked play.

But somehow the status indicators are not working.

Could it be a problem with the script?

Hello Peng,

Thank you for your patience.

Can you confirm if the Output tab in Unity shows any errors, and if so can you send a screenshot? I was not able to reproduce the issue. In both Unity Remote and in Editor, adding the prefab into the scene did not break anything after hitting Play.

The only time I ran into issues similar to yours was when I didn’t enter the session ID and click Start from the beginning. If I did anything else (such as attempting to connect the players) before starting up the session I wasn’t able to see the status indicators but that had no relation to the SyncStateTrackedPeer prefab.

Can you explain your use case for manually adding a SyncStateTrackedPeer prefab before hitting play? If you run the example and connect foo and bar, you will see that they are created automatically by searching for them in the Hierarchy search bar.

I just dragged the prefab “SyncStateTrackedPeer” and dropped it in the Canvas in my hierarchy.

I did not do anything else. Did I miss anything?

I tried to drop the SSTP prefab into the Shared AR template as well. The same error was produce. I got the feeling I must have missed something.


I tried to drop the SSTP prefab into the Shared AR template as well. The same error was produce. I got the feeling I must have missed something.

Hello Peng,

After looking into your issue a little further, if you need the connection status indicators to show up, what you actually need to add is the SyncStateTrackingList. It should already be there but after double checking the image you sent, it seems to be missing. Please try adding in SyncStateTrackingList to see if that makes the connected players list appear.

Lastly, as previously mentioned, there shouldn’t be a reason to add the SyncStateTrackedPeer manually. If this is still the case for you, please provide a use case for why you need to be able to do this. Otherwise, the SyncStateTrackingList should be what you need to display the list of connected users.