Unity won't let me add scripts to the camera

  • Issue category: ARDK Documentation / Unity Example Package /
  • Device type & OS version: Android
  • Host machine & OS version: Windows 10
  • ARDK version: 1.0.1
  • Unity version: 2019.4.33f1

Description of the issue:

Hello, I’m trying to follow the Basic Placement Tutorial, but after importing the ARDK package Unity won’t let me attach scripts to the camera. If I drag them directly to it it shows an error telling me to check the name of the script and the class are the same. If I try to attach it by searching with the Add Component button in Hierarchy it just doesn’t show any of the ARDK scripts.

I wasn’t able to recreate the issue on my end, however that error can be caused by the name of a script differing from the class name created in the script. Are you creating custom scripts outside of the ARDK or ARDK Examples packages? Have you tried replacing the default scene camera with the ARSceneCamera prefab, or tried using the ARSceneManager prefab?

Thanks for your reply. I was using the scripts that come with the ARDK package. However what seemed to work for me was downgrading from unity 2019.4.33f1 to version 2019.4.32f1 :sweat_smile:

Glad that you were able to resolve the issue.

This topic was automatically closed 2 hours after the last reply. New replies are no longer allowed.