VPS mesh size problem

Include the following details (edit as applicable):

  • Issue category: Lightship Maps / Semantic Segmentation / Multiplayer / Real-time Mapping-Depth / ARDK Documentation / Unity Example Package / Sample App aka ‘AR Voyage’ / ARDK Virtual Studio Tools / Developer Tools / Networking / VPS / Scanning Framework

  • Device type & OS version: Android / iOS / Other Ex. iPhone 8+ on iOS 13

  • Host machine & OS version: Windows

  • ARDK version: 3.0

  • Unity version: 2022.3.12f1

Description of the issue:
Hello again,
I’m making a “City Museum” like application, maybe I have to scan up to a hundred buildings and different objects of interest. Now I have 5 private meshes in my project for testing and they take up to 20 MB of space combined. So, 100 will take around 400 MB of space, which is a little too much for an application of this kind. Do you have any suggestions or is there any way to reduce the size of the meshes? Are public meshes saved in the unity project as well?
Thanks for the answer in advance.

Hey Pavle,

Each individual AR Location has a check box for including the mesh in the build. Is that currently enabled? If so, try disabling it to see if that shrinks the size.

Thanks, that helped. Is there any reason why to include mesh in the build? Is place recognition faster or something?

There is no improvement to recognition but in cases where you want to use the mesh itself in the scene or want to have effects such as occlusion to work then you would want to include the mesh. Otherwise, you can uncheck the box.