Xcode build has runtime error

ardk 3.0, iOS 14 build
Mac OS Monterrey
issue on device, iPhone iOS 16

  • Xcode version: 14.0.1
  • ARDK version: 3.0
  • Unity version: 2021.3.32f1 LTS

Description of the issue:
I’m trying to folow along on the Occlusion guide on the site. I’ve been following all the instructions, including adding a character from mixamo, and everything seems to work fine (it launches in play mode and animates), until I built the game and opened it in Xcode and try and launch to my device.
The app comes up blank on my iphone, and there is a run time error in this section…

id ufw = UnityFrameworkLoad();
[ufw runUIApplicationMainWithArgc: argc argv: argv];
return 0;

error details read:
[Subsystems] Loading plugin UnityARKit for subsystem ARKit-Meshing… [10:39:17.134149 -08:00] [—E—] [argeo/ardk-next/unity/cc/user/meshing/meshing_provider_api.cc:19] [thread 29903] assertion failed: meshing_interface.IsValid()

Edit: I’m also noticing I have a warning now in UNity editor,
“No active UnityEngine.XR.ARSubsystems.XROcclusionSubsystem is available. Please ensure that a valid loader configuration exists in the XR project settings.
UnityEngine.XR.ARFoundation.SubsystemLifecycleManager`3<UnityEngine.XR.ARSubsystems.XROcclusionSubsystem, UnityEngine.XR.ARSubsystems.XROcclusionSubsystemDescriptor, UnityEngine.XR.ARSubsystems.XROcclusionSubsystem/Provider>:OnEnable () (at Library/PackageCache/com.unity.xr.arfoundation@5.1.0/Runtime/ARFoundation/SubsystemLifecycleManager.cs:68)”

Can anyone help point me to a solution? I’ve uninstalled and reinstalled everyhting, changed version to 2022.3.13f1 to try, same result, error:


[18:12:45.683662 -08:00] [—E—] [argeo/ardk-next/unity/cc/user/meshing/meshing_provider_api.cc:19] [thread 574479] assertion failed: meshing_interface.IsValid()


I’ve followed the tutorial I feel precisely, except with a slightly newer version which it says should still be supported. Project Validation shows all green checkmarks.
I have a notice that saus “No active UNity.XR.Subsystems.XRCameraSubsystem is available. Please ensure that a valid loader configuration exists in the XR project settings.” but I don’t know how to solve that, and I cant understand why when I follow some of the video tutorials that are out there, I am getting different results from the simplest build.


I believe that I already helped you on our community Discord but will also put the solution we came to here to assist other users that might run into this.

It looks like for users who are only building for iOS and don’t have Android modules installed, the best version would be Unity 2022.3.10f1 which is specifically noted on our documentation to be supported and doesn’t carry that meshing_interface.isValid() error.

Hi, I have this very same problem it happens with just your ARDK 3.0 samples not just in my project.

Could you explain what I need to do to get this running on Unity 2021?

This is happening on a brand new computer, everything installed from scratch.
Unity 2021.3.32f1
Ios 16
Xcode 15.01

Just running your sample downloaded from:

No changes to it whatsoever.

It does work if i disable meshing, what is going on?

Try using the exact 2021 Unity version in the doc, that got mine working

I think the problem was that every time I was making a build I was choosing the “append” option, and I guess there were issues with that.

I rebuilt the xcode project in a different folder and it works now.