ARDK Scanning Feature : Crashes

Include the following details while filing a bug report (edit as applicable):

  • Issue category: Lightship Maps / Semantic Segmentation / Multiplayer / Real-time Mapping-Depth / ARDK Documentation / Unity Example Package / Sample App aka ‘AR Voyage’ / ARDK Virtual Studio Tools / Developer Tools / Networking / VPS /Scanning Framework
  • Device type & OS version: iPad Pro 11th generation
  • Host machine & OS version: Mac on 13.3.1 (a) (22E772610a)
  • Issue Environment : On Device
  • Xcode version:
  • ARDK version: 2.5.1
  • Unity version: 2020.3.1f1

Bug reproduction steps:

When we do a few continuous scans, creating a 3D model out of a real object. After few scans it will crash.

A few crashes a like :slight_smile:

  1. VoxelLib::MeshingEngine_CPU<_Voxel_s>::~MeshingEngine_CPU()

EXC_BAD_ACCESS (KERN_INVALID_ADDRESS)

  1. folly::threadlocal_detail::StaticMeta<void, void>::onForkChild()

EXC_BAD_ACCESS (KERN_INVALID_ADDRESS)

Hello M Mohan,

Unfortunately, iPads are not currently one of our supported devices. You can find our list of supported devices from our documentation here.

Please keep an eye on the Announcements page for future updates!

Hi @Stacy_Clifton

In your above reply, you gave this documentation link : Development and Runtime Requirements of ARDK — Niantic Lightship Augmented Reality Developer Kit release-2.5.2 documentation

I’m replying for the most of the system requirement questions.

  1. ARDK is officially supported on Unity 2020 LTS and Unity 2021 LTS.
    Tested with the above LTS versions.
    The project was being implemented in 2020.3.1f1.
    Also tested to 2021.3.xf1 LTS versions too.

  2. The officially supported Scripting Runtime Version in Unity is .NET 4.x Equivalent.

Yes runtime version was set to 4.x

  1. minimum version 13 : Yes, the version was set

  2. Developing with ARDK requires Mac OS Big Sur or better. Mac OS Catalina and earlier are not supported.

Yes using Mac OS, Ventura latest one, included the latest Xcode too.

  1. Tested the application with iPad Pro 11th generation with iOS version 16.4.1 , as well as iphone 12 pro with iOS version 16.x.x.

Hello M Mohan,

While the system requirements you listed are accurate, we do not support iPad devices and are unable to provide guidance with them at this time. However, I see that you also notice these errors on the iPhone 12, so I will focus our support on that device.

Could you please describe the steps you took that caused the errors to appear? For instance, are you just using the sample scene, or did you create your own scene with edited scripts, etc? I have been unable to reproduce the errors you see on iPhone, so any details you could provide would be helpful in our troubleshooting.

I have also got the same crash on iPhone 14 pro. 2. folly::threadlocal_detail::StaticMeta<void, void>::onForkChild()
EXC_BAD_ACCESS (KERN_INVALID_ADDRESS)
Attached is the stack trace for your convenience.

Crash happens when the scan process is almost done. Say about 95% done. Does not happen often. Could not find a pattern.

com.Joysticklab.Polymuse_issue_832e017a68e6343f9e97f0fe2aff7d4e_crash_session_8008a78031dc4278a9793dadcde36e0b_DNE_0_v2_stacktrace.txt (56.6 KB)

Hello Shubhra,

Could you please provide the versions of ARDK and Unity you’re using, along with your device iOS? In your testing, would the crash happen periodically and randomly under the same conditions, or was it after something was modified, etc.? Are you just using the sample scene?

Hi Stacy, for some reason I did not get any notification of your reply. Sorry for the late response.

ARDK Version: 2.5.1
Unity Version: 2021.3.11f1
iOS version: 17.2

The crash happens almost every time the scan is almost close to done. If the scan size is not too big, it works fine. I could reproduce it multiple times with a 2.5 m range, scanning some medium-sized objects. For example, a two-seat sofa scan crashed 4 consecutive times.

The strange thing is that it worked fine before I updated the OS. I have a lot of changes in the code, but the core scanning code has been the same. Also, the app was working fine without any crashes with the existing code. But after I updated iOS 17.2, it suddenly started this.

Edit: I just found that I am using 2.5.1, and there has been some significant bug fixes on scanning framework in 2.5.2, I will try out 2.5.2 and see it it fixes the problem.

Hello @Stacy_Clifton I have just reproduced the bug with the demo app provided by niantic. The settings are following:

ARDK Version: 2.5.2
Unity Version: 2021.3.11f1
iOS version: 17.2

Scanning Framework Settings:
Reconstruction Mode: Detail
Mesh Quality: Very High
Texture Quality: High
Range: 2.5m

I tried to scan a 3 seat sofa, which can be considered as a medium size object.

Update Nov5 - 6.20 pm: I have turned down the mesh quality to medium and tried out 10 scans. It did not crash with the setting. But the mesh quality is a bit poor.

Hello @Shubhra_Prakash_Sark,

Thank you for the information!

We recently had a report of a similar issue with iOS 17.2 and Scaniverse (it uses the same engine for scanning and processing as Scanning Framework). We are currently investigating internally, but I will reach out again once I have any more information. Thank you for letting us know!

2 Likes

Hello @Stacy_Clifton , do we have any update on this issue?

Hello @Shubhra_Prakash_Sark , thank you for patience in this.

It seems that Apple has resolved the bug with iOS 17.2, but are you still experiencing crashing?

I tested the Scanning scene in ARDK 2.5.2 on device (iOS 17.2.1) and Unity 2021.3.17f1 but have been unable to reproduce the crashes so far. I am consulting the team again to try and get to the bottom of the issue.

Just to confirm, I know you had said that it works fine if the scan is not too big, but at what point does it stop working? (for instance, is everything fine as long as you scan for less then 5 minutes, etc.).