Black screen - shared AR

Include the following details (edit as applicable):

  • Issue category: Multiplayer / ARDK Documentation / Unity Example Package / ARDK Virtual Studio Tools / Developer Tools / Networking
  • Device type & OS version: Android (Xperia XZ2)
  • Host machine & OS version: Windows 10
  • Issue Environment : On Device
  • ARDK version:2.0
  • Unity version:2020.3.20f1

Description of the issue:
according to the Lightship Guides – Niantic Lightship,
I create the project called Lightship Ball Demo
and follow the step of The Basics.
I got the first app called Lightship Ball Demo and it works well.

However in the same project I create the scene call SharedAR
and follow the steps of Shared AR Session & Plane Tracking,
I got the second app and it always give me the black screen.

I use the same setting in this project and the first app works well so I don’t think the problem is camera setting or Android setting.

If anybody knows how to solve it please tell me, thanks.

actually I also faced this problem.

However, after tapping on the screen for a while, scanning the room, it will show the camera already.

did you attach the android permission?

Hello Peng_Han_Kum
It’s a good question.
when I open the app , the system didn’t ask me the permission of camera.
So I am going to the setting to give the camera permission to both app.
If you need any infomation about question, please let me know, thanks.

okay, try attaching the android permission script to any game object.

for more info, look up in the niantic forums or documentation for the android deployment.

Did you open up playing settings to configure it?

Now I wirte some codes to Request User Permission of camera.
Unfortunately, even user allow the permission of camera, it’s still the black screen

hi, same too!

i followed ‘the basics’ tutorial for my IOS device, no issue.
however, i followed the shared AR and plane tracking tutorial, when i tapped on my phone it shows nothing.

so not sure how to solve this too :confused: