Can't get the Augmented model show up using VPS

Include the following details (edit as applicable):

  • Issue category: VPS, Niantic Wayfarer
  • Device type & OS version: Android
  • Host machine & OS version: Windows
  • Issue Environment : On Device (Samsung S8 Tablet)
  • ARDK version: 3.2.0
  • Unity version: 2022.3.16f1

Description of the issue:

Here’s the story that drives me crazy - I have used the Niantic Wayfarer to get couple private scans and tested out the VPS function successfully. Then we wanted to test a spot in another city. My coworker logged in the same Niantic Wayfarer account and scanned an object with his tablet (scan number: d8df2be84cd94a43b2724a268317dcbb.107). Then I downloaded the zip file and used in the same Unity project I used for previous tests.

All settings the same in a seperated Unity scene. However, on my coworker’s tablet, he never got the agumented model showed up. (We both use Samsung S8 tablets.)

Help really needed (

drowning face :frowning:


If I’m understanding correctly, you are each building separate scenes that are supposed to do the same or a similar thing correct? Or at the very least, both of these scenes are using the same AR Location, right?

If that is the case, that means that both scenes would need to have their own ARLocationManager so the first thing to do is make sure that each scene has an ARLocationManager in its XROrigin.

Next, make sure that your scan was added as an AR Location. If it was then it should appear as a child of the XROrigin. If it’s there, check to see if the Location has “Include Mesh in Build” checked. Otherwise, the digital scan of the real world object that you scanned will not be included in the Unity build.

Thanks for your reply Jesus.

Under my test Unity build, I just have one scene, one scan (AR Location) and one pop-up AR-model.

I tested the build with success but when trying to use another scan (AR Location) I got nothing.

So, basically in these two cases the processes are all the same, except for one variation that the second scan was taken by a different device by my coworker. That’s why I’m so confused.

And regarding the solution you provided. I think I set everthing correct because I knocked things out in my first test, although I toggled off “Include Mesh in Build”. I will try to turn it on and see what will happen.

And if you get any idea with my added description please let me know. Thanks again!

Yes, if you’re saying that the option for “Include Mesh in Build” is not enabled, then enabling it will include it when you build your project. Since both scenes will have their own ARLocationManager and ARLocations, make sure the setting is toggles in the ARLocations in both scenes