Hard shadows on the map

  • Issue category: Lightship Maps
  • Device type & OS version: Windows 11
  • Host machine & OS version: Windows
  • Issue Environment : Unity

Description of the issue:
Hi, whenever I start a new scene from scratch I end up with hard shadows on the map. I’ve setup the new scene exactly (as much as I can find) the same as the Third-Person Camera Sample but can’t seem to find the issue.
I’ve verified that the Directional Light and Camera Rendering and Environment are set up the same.

I’m guessing it’s something simple that I’m missing but can’t seem to find it. Any ideas what else it could be?

Bad (When creating a new scene):

And here is what the Third-Person Camera Sample looks like:

I found the issue. The Third-Person Camera Sample has the environment lighting set to color instead of skybox (the default for a new scene).

So, if you are trying to recreate the Third-Person Camera Sample in a new scene you need to go to
Window > Rendering > Lighting. Click Environment and change the environment lighting source to Color.

This topic was automatically closed 2 hours after the last reply. New replies are no longer allowed.

Hi Davy,

Something you can try is turn off “Receive Shadows” on all the materials used by the map. You can find all the materials used by the map by going to the Map Theme, selecting each builder under “Builders” in the Inspector, and selecting each material under “Materials” for that builder. Alternatively, as it looks like you’re using the default Light theme, you can browse to Packages/Lightship Maps SDK/Themes/Light/Materials/Lit/URP to find all the materials.

Kind Regards,
Maverick L.