Human occlusion issue in ARDK3

Include the following details while filing a bug report (edit as applicable):

  • Issue category: Real-time Mapping-Depth /Occlusion
  • Device type & OS version: iOS
  • Host machine & OS version: Mac
  • Issue Environment : On Device
  • Xcode version: 14.2
  • ARDK version: ARDK 3 beta
  • Unity version: 2021.3.27

During the testing of ARDK 3, I noticed that environmental occlusion was still happening even though we had set the occlusion mode to human occlusion in the AR Occlusion Manager. So the already existing ARFoundation project causes a degradation in the quality of occlusion.

Hello Naveen,

I see you submitted a similar request some time ago. Sorry for not having gotten back to you on that one but I was wondering if you’re still experiencing the same issue or is this a new issue? If this is a new issue, can you provide an updated screenshot of your AR Occlusion Manager as well as a description of what’s happening?

If it’s the same issue, I see you uploaded an image of the occlusion manager on the older post but there wasn’t a description of the behaviors you expected. If the behavior you were expecting was only human occlusion and no environmental occlusion, you didn’t have environmental occlusion disabled in that screenshot so it was still going to process.

Hi @Jesus_Hernandez ,This is a new issue, Upon checking the ARDK3, the environmental occlusion is still affecting the system despite selecting human occlusion in the occlusion manager. This indicates that there is no difference between environmental occlusion and human occlusion.

Hi Naveen,

Have you tried seeing what the difference is when selecting “Prefer Environment Occlusion” to get an idea of how occlusion performs based on the preference? Both are still enabled and are set to Best. Also, do you still require assistance on your other issue or has that been resolved?