Low FPS on Android build

  • Issue category: Scanning Framework
  • Device type & OS version: Android (xiaomi redmi note 12 pro)
  • Issue Environment : On Device
  • ARDK version: 2.5
  • Unity version: 2021.3.29f1

Description of the issue:
I’ve managed to build to iOS with no issues, scanning works great.
However, building to my Android (following your guide on build settings), I get 30 - 50 fps. When I create a new AR session and display the camera feed I get a constant 30 fps.
The target fps in the project is set to 120 (as my Android support 120hz) and vsync is 0.

Any ideas how I can debug this issue?

Hi Arvid,

May I know how/where you’re setting the frame rate?


I’m setting Application.Framerate = 120 on Start() in my ScanController, which is active when launching app.

Edit: Solved the issue by turning off “Optimized Frame Pacing” in player settings. This was a known bug for Xiaomi smartphones.

This topic was automatically closed 2 hours after the last reply. New replies are no longer allowed.

Hi Arvid,

Glad to see that you were able to resolve this!