Playback problem

Include the following details (edit as applicable):

  • Issue category: Real-time Mapping-Depth / ARDK Documentation / Unity Example Package / Developer Tools Scanning Framework
  • Device type & OS version: iOS
  • Host machine & OS version: Mac
  • Issue Environment : On Device
  • Xcode version: 13
  • ARDK version: 3
  • Unity version:2021.3.38f1

Description of the issue:

I have a problem when try to setup playback for app testing. I have tried on “Normal Mesh” scene from lightship samples. 2 errors occur:

[Error] Request kDepthSemantics_Frame missed a callback, likely because OnReceiveFrameData() takes longer than it should

InvalidOperationException: No environment prefab set. Pick an environment in a Scene View with Overlays → XR Environment.
UnityEngine.XR.Simulation.BaseSimulationSceneManager.SetupEnvironment () (at Library/PackageCache/com.unity.xr.arfoundation@5.1.0/Runtime/Simulation/BaseSimulationSceneManager.cs:88)
UnityEngine.XR.Simulation.SimulationSessionSubsystem+SimulationProvider.SetupSimulation () (at Library/PackageCache/com.unity.xr.arfoundation@5.1.0/Runtime/Simulation/Subsystems/SimulationSessionSubsystem.cs:136)
UnityEngine.XR.Simulation.SimulationSessionSubsystem+SimulationProvider.Initialize () (at Library/PackageCache/com.unity.xr.arfoundation@5.1.0/Runtime/Simulation/Subsystems/SimulationSessionSubsystem.cs:50)
UnityEngine.XR.Simulation.SimulationSessionSubsystem+SimulationProvider.Start () (at Library/PackageCache/com.unity.xr.arfoundation@5.1.0/Runtime/Simulation/Subsystems/SimulationSessionSubsystem.cs:73)
UnityEngine.SubsystemsImplementation.SubsystemWithProvider`3[TSubsystem,TSubsystemDescriptor,TProvider].OnStart () (at /Users/bokken/build/output/unity/unity/Modules/Subsystems/SubsystemWithProvider.cs:55)
UnityEngine.SubsystemsImplementation.SubsystemWithProvider.Start () (at /Users/bokken/build/output/unity/unity/Modules/Subsystems/SubsystemWithProvider.cs:10)
UnityEngine.XR.ARFoundation.ARSession.StartSubsystem () (at Library/PackageCache/com.unity.xr.arfoundation@5.1.0/Runtime/ARFoundation/ARSession.cs:396)
UnityEngine.XR.ARFoundation.ARSession+d__39.MoveNext () (at Library/PackageCache/com.unity.xr.arfoundation@5.1.0/Runtime/ARFoundation/ARSession.cs:384)
UnityEngine.SetupCoroutine.InvokeMoveNext (System.Collections.IEnumerator enumerator, System.IntPtr returnValueAddress) (at /Users/bokken/build/output/unity/unity/Runtime/Export/Scripting/Coroutines.cs:17)

My recording is running as empty asset in the app background (with not working app features) until I activate “Niantic Lightship Simulation” in “XR Management”. After I check this box, the errors I described above appear.
Please support me.
BR,
Greg

Hello,

If both playback and simulation are two different debug features and only one can be used at a time. Would you be able to clarify which of the two you’re attempting to use so that I can better assist you?

Hi,
I see that simulation is required to be enabled when playback is used. 2 cases I tried:

  1. Playback active without simulation enabled. Result: I see my recording but AR features can’t see it.
  2. Playback with simulation enabled. Result: errors I described above.

I’m sorry. Seems I wrong understood the settings should be. So let’s consider only my first configuration (which should be set): Playback without simulation enabled. Any idea why AR can’t recognize the recording?

Can you show me the rest of your setup for Occlusion? Mainly the Occlusion Manager?

Hi,
This is not only about the Occlusion. The problem same is in Meshing and other samples.
Occlusion and other works perfect after build the app. Anyhow Below you can see occlusion manager settings (if it could give any clue).

BR,
Greg