AR Voyage stuck at 97% loading on Galaxy S20 Ultra 5G

Include the following details while filing a bug report (edit as applicable):

  • Issue category: AR Voyage
  • Device type & OS version: Galaxy S20 Ultra 5G
  • Host machine & OS version: Android 11
  • Issue Environment : On Device
  • Xcode version:
  • ARDK version:
  • Unity version:

Bug reproduction steps:
Open app on device, never progresses past 97%

arvoyage_logcat.log (16.0 KB)

Hi Blake,

Please take a look at our documentation on Building ARDK Apps for Android.

Can you please follow the instructions under the section “Building for Android 11 (API level 30) and higher”, in case you haven’t followed them?

If the issue still persists, can you share your ARDK and Unity Versions along with any other error information and screen recording(if possible)?


This is the Play Store version, not the source version. I haven’t tried building myself.

Hi @Blake_Gross, I went to reproduce this issue, and I noticed that this will occur if you have location services turned OFF on a device level when launching the app. Would you please check that location services are enabled for the phone that you are using to run the app? You may also need to enable camera permissions to load into the app if you’re not prompted to enable them on relaunching.

Can confirm that was the issue. Turning location on for the device fixed it. Thanks!