ARDK 3.4 Image Tracking

Include the following details (edit as applicable):

  • Issue category: ARDK
  • Device type & OS version: Android
  • Host machine & OS version: Windows
  • Issue Environment : On Device
  • Xcode version:
  • ARDK version: 3.4
  • Unity version: 2022.3.3f1

Description of the issue:

hello. I’m using LightShip ARDK well, but I’m trying to use ImageTracking, but I don’t have any related information, so I’m inquiring. Is there a separate tutorial?
ARFoundation’s ARTrackedImageManager does not work with Niantic LightShip SDK + Google ARCore in XR Plugin, but works with Google ARCore. I would like to use it with other features of LightShip.


Since ARDK is using ARFoundation’s image tracking, we don’t provide tutorials or documentation for it since it’s not exactly an ARDK feature. Our documentation only touches on the Lightship/ ARDK specific features as well as any ARFoundation features that the SDK extends functionality for.

You can reference Unity’s ARFoundation documentation for Image Tracking:
You can also use any tutorial that’s using ARFoundation 5.1 since that’s the version we use as a dependency

Also, please share any error messages you’re getting with ImageTracking. ARFoundation features should still work when using the Lighsthip SDK + ARCore (or ARKit) option since it requires ARFoundation to run

The project settings are as follows.

if Google ARCore is checked, image tracking works well, but if Niantic LightShip SDK + Google ARCore is checked, image tracking does not work.

The log cannot be uploaded because the TXT file is not attached. When comparing the logs from the two situations, there doesn’t seem to be much difference.

  • Here are the build results:

Thanks for these screenshots. I’ll give it a go myself and will raise this bug to our team.


I tested both ARCore and ARDK 3.4 and both were spawning the test cube I attached to the tracked image manager. The only issue I experienced at first was that the cube appeared to not be spawning but after taking a few steps back I was able to see it.

Have you tried moving around to see if the cube might be rendering around the device instead of in front of it? Are you also able to show what the Android Logcat outputs on the Lighship SDK build?

Since I am a new member, I can only upload one image.

When using “Google ARCore”, I looked around and looked at the image, and a cube appeared. When using “Niantic Lightship SDK + Google ARCore”, the cube does not appear even when I look around and look at the image.

Got it. Let me take a look at these logs and I’ll get back to you. I did also want to confirm with you if you’re switching between both AR packages in the same project or if you’re using different projects for each AR package. The reason I ask is that if you have Lightship installed, you can’t pick the standalone ARCore or ARKit even if you uncheck Lightship. If you do, it’ll just automatically default back to Lightship SDK + ARCore (or ARKit)

If you’re able to switch between Lightship SDK + ARCore and only ARCore in the same project it might be an issue with the download of Lightship.

hello. The project I used before worked as is even if I checked “Google ARCore” and “Niantic Lightship SDK + Google ARCore” respectively.

When I imported ARDK into a newly created project, when I checked “Google ARCore”, it was automatically unchecked and “Niantic Lightship SDK + Google ARCore” was checked. I tried image tracking in this state, but tracking did not work due to the same symptoms.

Ok, that is to be expected when Lightship is installed. Can you try this on Unity version 2022.3.16f1?

I know it’s a minor change but we’ve noticed in the past that there were Unity specific nuances that would affect builds with Lightship. Can you try that version of Unity to rule that out? It’s the version of 2022 that Lightship officially supports.

I tested it on 2022.3.16f1, but image tracking still does not work.

Thanks for trying. Are there any other managers you’re using or is it currently just the Tracked Image Manager?

I am only using the AR Tracked Image Manager in the XR Origin object.

Can you go into the Play Store and search for Google Play Services for AR?
Check to see if it’s up to date, if it’s not, update it.
If it is up to date, see if you can uninstall it and reinstall it.

Let me know how that goes :slight_smile:

Even if I delete and reinstall Google Play Services for AR, it doesn’t work the same way. Can I use ARDK 2.5 version?


Would you be able to provide me with new logcats of both Image Tracking with only ARCore and also with Lightship + ARCore? I’m assisting another user with a similar issue and both your logs and theirs don’t seem to indicate anything about image detection not working. I’m hoping that maybe the logs with the standalone ARCore will maybe print out some information that can give us an idea of what is happening with Lighthsip SDK.

To answer your question on 2.5, we have officially ended all support for it last month so it is no longer available for download.