ARGameLogic.cs script error from building with VPS tutorial

Include the following details (edit as applicable):

  • Issue category: VPS
  • Device type & OS version: Android / iOS
  • Host machine & OS version: Windows
  • Issue Environment : Unity Remote
  • Xcode version:
  • ARDK version: 2.0.0
  • Unity version: 2021.1.15f1

Description of the issue:
In the tutorial Building with VPS, there are several issues.

First issue
In the SaveLocalReference() function, wayspotAnchors does not contain ‘Select’ and it gives me an error. However in Tricia’s video, Select is found and she has no error.

Second issue
The type or namespace name ‘Serializable’ could not be found and gave me an error. However in Tricia’s video, She has no problem with Serializable.

Third issue
Under tutorial Step 5: Connection to Wayspot Service,

in the youtube video (timestamp - 15:15), Tricia states the bottom code
var locationService = LocationServiceFactory.Create(session.RuntimeEnvironment);

However in the documents, the code in the image is as follow
var locationService = LocationServiceFactory.Create(Manager. ARSession.RuntimeEnvironment);
wayspotAnchorService = new WayspotAnchorService(Manager. ARSession, locationService, wayspotAnchorsConfiguration);

additional manager and ARSession is found, whereas in Tricia’s code, there is no manager and ARSession.

I tried using the following solution
using System; ← to remove first issue error
using System.Linq; ← to remove second error


I am unable to instantiate mushrooms in the environment.

I have no idea where the problem lies now, hope someone can help me.

Thank you


Hello Peng Han Kum – welcome to the Lightship development community!

Thank you for identifying and reporting the issues you found with the Building with VPS tutorial. We have been able to identify and reproduce the errors on our end, and we’ve informed the team of the issues.

You were correct that in order to compile the ARGameLogic.cs script, you will need to add using System; and using System.Linq; to your script header. Additionally, you will need to add your own prefab GameObject instead of the mushroom. You can add a simple cube prefab for testing purposes.

Also, in the OnSessionStarted() method, be sure to subscribe the OnSessionStarted() method to the Ran event handler using the following line…

session.Ran += OnSessionStarted;

…as this method contains the application’s location service and wayspot anchor service initialization.

As for the pink material floor plane, can you navigate to the PlanePrefab asset, double-click it to open it up and ensure the Plane child GameObject’s material is using the Unlit/PlanefindingGrid shader?

Thank you again for reporting the issues you found, and let us know if you have additional questions.


For the PlaneFindingGrid: I also had the problem, that it was pink in my (non URP) project.
Fixed it by creating a new Shader for it, with these settings.

Hope that helps


I found the plane finding " **PlanefindingGrid" shader was broken for my system (not sure why)
But if you comment out line 25 //#pragma exclude_renderers d3d11
it should work.

thanks though I love lightship
But yes hope this tutorial gets fixed as I really want to play with it!!

I have the same problem wit that script.

This topic was automatically closed 2 hours after the last reply. New replies are no longer allowed.