Low level networking scene gives error

After 3 months thought i was going to give it another go… I’d really like to give it for a spin, but…

macbook M1
Ventura 13.1
Unity 2022.2.16 (…and some other flavours… same problem…)

Followed all the steps (around 5 times now)
Trying to run the lowlevel networking scene and this error:

#Niantic.ARDK.Extensions.NetworkSessionManager#: Failed to create a MultipeerNetworking session because _useWithARNetworkingSession is true but no stage identifier was specified.
UnityEngine.Debug:LogError (object)

1 Like

Hello Mike,

Have you made any changes to the Low Level Networking scene, or are you just running it as-is? I was able to successfully run the scene, but I noticed that the Use With AR Networking Session was set to false by default in my Inspector. I was able to reproduce this error if I ran the scene with that box checked. Could you please check your ExampleManager and try unchecking the box to resolve the error?

I’m just trying this for the first time (yay!) but I’m running into this same issue. by Default “Use WIth AR Networking Session” is unchecked, but the tutorial doesn’t mention checking it after changing Runtime Environment to “Live Device”.

Okay, sorry for posting so quickly after my question, but after a little rage clicking, I noticed that if I disregard the specific instructions to Change the Runtime Environment to “Live Device” and just leave it at Default, I do get a connection to work.