Template SemanticMasking Error

  • Problem category: semantic segmentation
    Device type and OS version: iphone11 pro / iOS 15.5
    Host machine and OS version: macOS Monterey version 12.4
    Issue Environment : Unity Mock / on device
    Xcode version:13.4
  • ARDK version:2.0.0
  • Unity version: 2020.3.35f1

Problem Description
I ran LightshipHUB/Samples/Contextual Awareness/SemanticMasking.unity
but cannot confirm the operation due to the following error. Please tell me how to fix the error.

A game object can only be in one layer. The layer needs to be in the range [0. .31]
StackTraceUtility:ExtractStackTrace ()
Niantic.ARDK.Templates.ObjectMasking:SetLayerToGameObject (UnityEngine.GameObject,string) (at Assets/LightshipHUB/Runtime/Scripts/ObjectMasking.cs:43)
Niantic.ARDK.Templates.ObjectMasking:SetLayerToGameObject (UnityEngine.GameObject,string) (at Assets/LightshipHUB/Runtime/Scripts/ObjectMasking.cs:48)
Niantic.ARDK.Templates.ObjectMasking:Awake () (at Assets/LightshipHUB/Runtime/Scripts/ObjectMasking.cs:16)
A game object can only be in one layer. The layer needs to be in the range [0…31].
StackTraceUtility:ExtractStackTrace ()
ObjectMasking:SetLayerToGameObject (UnityEngine.GameObject,string) (at Assets/LightshipHUB/Runtime/Scripts/ObjectMasking.cs:43)
Niantic.ARDK.Templates.ObjectMasking:Awake () (at Assets/LightshipHUB/Runtime/Scripts/ObjectMasking.cs:16)

Hello Noriko,

We need additional information to reproduce your issue. Could you please provide the detailed steps you took to set up your project?

Thank you.

Thank you for contacting us.

I get an error when I run β€œplay” in Virtual studio / Mock Play Configuration.
Please find attached a screenshot.

Hello Noriko,

Thanks for the screenshot.
I was able to reproduce your issue by not having a license key in the Lightship HUB - Configuration Helper Window.
Can you please try with fresh SemanticMasking unity project and follow the below steps,

  1. Import latest ARDK, ARDK Mock environments, Lightship Hub, and Lightship Mock environments packages to project.
  2. Skip creating the Resources folder and setting the ARDK auth key in the ARDK folder.
  3. Click on Lightship - > Lightship Hub β†’ Configuration Helper Window.
    Add Auth key, click setup β†’ you will see a success message.
  4. Add the ARDK_MockWorld layer to the mock environment prefabs and their children.
  5. Open Mock Play configuration, and select ParkPond Mock scene.
  6. Run the project in unity.
    With the above steps, we were able to run without any console errors.
    Please refer, to this documentation, for how to set up a License Key.
    If the console errors persist even after the above steps, please let us know.

Hope this helps you.

1 Like

Hello Umaiya,

Thank you for your reply.
Thanks to you, we were able to solve the problem.

This topic was automatically closed 2 hours after the last reply. New replies are no longer allowed.

Hello Noriko,

Excellent. I’m glad you were able to resolve the issue.