ARDK + iOS Opening unity in an iOS project crashed

Include the following details (edit as applicable):

  • Issue category: crashed
  • Device type & OS version: iOS 15.5
  • Host machine & OS version: Mac M1
  • Issue Environment : Unity
  • Xcode version:14.1
  • ARDK version: ardk- 2.3.0
  • Unity version: 2021.3.13f1

Description of the issue:
I introduced the unity project into my iOS project. After a series of operations, I ran my iOS project and a crash occurred:
dyld[77675] : Library not loaded: @rpath/ardk_client_platform.framework/ardk_client_platform
dyld[77675] : Library not loaded: @rpath/infinitam.framework/infinitam

After I changed these two frameworks to optional, this problem was solved, but after I successfully ran my iOS project, when I clicked the button to jump to the unity interface, the system crashed
and the crash stack was on this line
// Native function invocation|

My mobile phone is iphone8P. It is no problem to run the project exported by unity alone, but it will crash when called as another project

Hi @wangziwei,

ARDK is not officially supported when using Unity as a library at this time. However, we’ll keep this thread open in case any of the community members have any experience and/or input.

I am having the same issue, is there any workaround this problem, so that I can create Additional Screens for the app using ARDK/Lightship?

Please have a look at this post, I try to adress the library problem there: