Black screen in Depth Display sample

Include the following details (edit as applicable):

  • Issue category: Real-time Mapping-Depth
  • Device type & OS version: iPhone XS on iOS 14
  • Host machine & OS version: Mac
  • Issue Environment : On Device
  • Xcode version: 15.3
  • ARDK version: 3.3
  • Unity version: 2021.3.33f1

Description of the issue:

I am running the Depth Display demo included in the official ardk-sample on an iPhone XS with iOS14 installed. As you can see in the attached video, it appears almost completely black. Is this an issue with ARDK? Or could there be some problem with the settings?

Hello Takahiro,

Could you go to Project Settings → XR Plugin Management → Niantic Lightship SDK and send me a screenshot of that page. Also, while on that page, try checking to see if the “Prefer LiDAR if Available” is toggled on. If so, you could try toggling it off and then building again to see if that solves your problem.

I have attached a capture of “Niantic Lightship SDK” screen. As you can see, ‘Prefer LiDAR if Available’ was turned ON, so I tried turning it OFF and testing it, but the result was the same (the screen turns black in Depth Display). I’m not sure if this will be helpful, but I’ll also send you the settings of the MainCamera to which the AROcclusionManager component is attached in Depth Display scene.

Do you notice any errors on Xcode while building and running the project on your phone?

There’s an update. I tried using another device: iPhone X, and it seems that DepthDisplay is working fine on it. However, when I tried it on an iPhone XS, DepthDisplay almost turns completely black. I will attach a comparison image.

I will attach the Xcode log, but there were no particular errors. However, on the iPhone X, it says “This device does not have a Neural Engine, so Core ML delegate will not be enabled,” whereas on the problematic iPhone XS, it shows a log that the CoreML delegate is being used, stating “coreml_version must be 2 or 3. Setting to 3.”
iphonex_xcode.log (12.2 KB)
iphonexs_xcode.log (12.9 KB)

I would appreciate it if you could check this.

@Josh1 Do you have any updates on this issue?

This appears to be a bug with the iPhone XS. We are currently looking into the problem.

1 Like

I have an update: The issue was resolved after updating the iPhone XS from iOS 14 to 17.4.

That’s great! I’m glad to hear you got it resolved. We did testing on our end and also found that the OS version was causing the issue so upgrading was the solution.