Link unityFramework(arm64) Framework not found error

  • Issue category: Unity Example Package and IOS Build
  • Device type & OS version: iPhone X on iOS 15.2.1
  • Host machine & OS version: Ex. Mac on Big Sur 11.6.2
  • Issue Environment : Building on Xcode
  • Xcode version: Xcode 13.2.1
  • ARDK version: ardk-1.1.0
  • Unity version: 2019.4.9f1 LTS

Bug reproduction steps:

I followed the Unity setup to the letter. I used the same version of Unity that’s in the docs, my license key is good, i followed this doc perfectly : Niantic AR Development Kit (ARDK): Building the ARDK-Getting-Started App for iOS installing all the Frameworks manually that did not show up in Xcode. But after all this when I did the build I keep getting this error no matter what: link unityFramework(arm64) Framework not found error

I am Building to a IPhone X
I am using Xcode 13.2.1 I don’t have any problem building other IOS apps via Unity so its definitely a problem with ARDK. I also tried changing from ARM to Universal and back again just in case that was the problem.

Please help. Very frustrating. Been at this for about 5 hours and I’m about to give up and look for another commercial solution out there.

Hi Michael,

Sorry to hear that you’re facing this issue. Can you please check the target architecture for your build is set to arm64? If it’s not then it would definitely cause a problem since we only target arm64.

To fix this, you can add arm64 to Project → Build Settings → Architectures in X code, or directly from Unity (in the build settings > player settings inspector window > Architectures, (screenshot attached)). Please give this a try and let us know if this resolves the issue. Thanks.

I’ve also ran through similar issues to this as well using the same settings. The exceptions:

Unity version: 2019.4.21 LTS

Is there any development on this? I’ve also ensured that I was building using arm64 architecture on both the build settings and in the unity settings with no luck as well.

Hi Danny,
Thanks for writing in. Please open a new topic to get help with this issue.

Xcode Setting.
Step 1:

Remove “null.framework” in Target->UnityFramework->General-> Frameworks and Libraries

Then set Enable Bitcode to “NO” in " Targets → UnityFramework-> Build Settings → Build Options → “Enable Bitcode”->No
And also Targets → Unity-iphone-> Build Settings → Build Options → “Enable Bitcode”->No

Step 2:

Targets → Unity-iphone → General → Frameworks,Libraries, and Embedded Content add + ARKit

Step 3: Rebuild
Pls let me know if it work. Thank you.