Unable to create build for iOS as validation fails stating ARDK.Framework does not support the minimum OS version

Include the following details (edit as applicable):

  • Issue category: ARDK
  • Device type & OS version: iOS
  • Host machine & OS version: Mac
  • Issue Environment : iOS Build validation
  • Xcode version: Latest
  • ARDK version: 2.4.2
  • Unity version: 2021.3 (with URP enabled)

Description of the issue:

I can build and run an application on device, built and deployed through xCode following a Unity build onto a device.
However, whenever I try and archive the project for publication to TestFlight, I am halted by the following error:

“the bundle “ardk.framework” does not support the minimum os version specified in the info.plist”

After much fighting with Unity, I got Unity to set the iOS version to 11 (same as another app we have), however, If edited manually, Unity FORCES Version 12.0 by default.

But regardless, building the app targeting 11.0 or 12.0 results in the same failure in Validation or Upload.

Any ideas as I’m now at a loss after 2 days trying.

1 Like

Have also tried creating a blank project and adding the ARDK and get the same result in Unity 2021.

Tested building and validating the Blank project prior to adding the ARDK and it builds and validates fine for iOS

But simply adding the ARDK hits the reported issue about version issues.

1 Like

@SimonDarksideJ I can confirm this too. I’m running into validation issues with Xcode using Unity 2021 and 2.4.2

Glad and not glad it’s not just me. I get it with both 2.4.1 and 2.4.2

1 Like

I dropped down to 2.3.2 and I was able to get it through. Don’t know if that helps?

I will check the release notes and try. The crazy thing is we have one app built with 2.4.1 which is building and I am at a loss as to why, we are still investigating.

Thanks for the nudge @Todd_Little

1 Like

@SimonDarksideJ don’t know if you are on Discord, but you might check this out: Discord

Thanks for the heads up @Todd_Little , that did eventually lead to a resolution.

I put the fix on Discord, but also putting it here for those using the forums:

  • Import the ARDK in to your Unity Project
  • In your Project view, navigate to - Assets/ARDK/Plugins/iOS/ARDK.Framework
  • Double-click the file to edit the “info.plist” file located in the folder
  • Find the “MinimumOSVersion” property and change it from “9.0” to the iOS version in your project (I updated mine to 11.0)

You should not be able to successfully archive, validate and finally upload your build to the Store or TestFlight.


Hello Simon and Todd,

Thank you both for bringing this to our attention, and I apologize for the inconvenience it has caused. I have passed this information along to the team so they can further investigate and prevent this issue from occurring in the future.

Noted as updated in the 2.5.2 release, info.plist in the package has been updated to 11.

Hi, I also have the same problem.
ardk.framework does not support the minimum os version specified in the info.plist

How can I solve the problem?

Hello @Aw1,

Could you please provide what version of Unity and ARDK you’re using, along with your device type and OS? I was able to build with ARDK 3.0 in Unity 2021.3 with no issues.

Have you checked the resources listed above by other users to see if that solves your problem?