Multiplayer/Netwrok ArCamera non detecting (Android)

  • Issue category: Multiplayer / Networking
  • Device type & OS version: Android OPPO Find X3 Lite Android 12
  • Host machine & OS version: Windows 10
  • Issue Environment : On Device
  • ARDK version: 2.0.0
  • Unity version: 2021.3.4f1

Description of the issue:
Hello, I am working on an application that includes multiplayer. After following the available tutorials, I find myself at a dead end. While trying to test my application on my Android, two things happen: If I put the Runtime Environment to Live Device in the AR Session Manager and the Network Session Manager, then the application returns me an error about using netwroking without an API key (the key is existing and is in the right folder). On the other hand, if I set the Runtime Environment to Mock, I can connect to my application, but I cannot access my camera. Here is a screenshot of the situation.

Any idea why it is not working properly ?

the application returns me an error about using netwroking without an API key (the key is existing and is in the right folder)

That can be caused by having more than one ArdkAuthConfig. If you installed the examples package then remove the one inside the ARDKExamples/Resources/ARDK folder.

If you are following the first Getting Started Tutorial I would recommend not using this interface for validating the API-key. I had lots of problems with the setup, but when I followed this one (Tutorial: Basic Placement — Niantic Lightship Augmented Reality Developer Kit release-2.0 documentation) it worked way quicker and easier.

Thank you for you reply, but I do have only one API key in my project.

I have other scenes in my projects that are working well with the ARCamera. Only the SharedAR one is porblematic.

Hello Bastien,

We tried to reproduce the issue, however, we couldn’t.
Everything worked as expected on our end but in the process, we found some areas worth double checking.-
Can you please confirm the following?

  • Have you removed the Vulcan API from Build Settings → Project Settings → Player → Other Settings > Rendering > un-check the box for Auto Graphics API for Windows to show the list of available Graphics API for Window and then remove Vulkan from the list.
  • Are you using correct API Key which you have generated in Sign in – Niantic Lightship. If you created your own Resources/ARDK folder to hold the AuthConfig, make sure it’s spelled correctly, has correct casing, and ensure that the Resources folder from the examples package is deleted even if you didn’t paste an API key in it.
  • To access your device camera, you should have an AndroidPermissionRequestor script component set to a value of 1 with a Camera element.

Please refer to the Set up camera permission for Android. Can you also verify your app has permission for the camera on the device? or try deleting the build off your device, rebuilding and redeploying, and see if you get the camera permission pop-up?

Please let us know if this helps!

Thank you for you reply,

I solve it ! the problem was that i named the folder with the API Key Ressources instead of Resources

Thank you for your help everyone !

Hi Bastien,

Glad that you were able to resolve the issue.