GfXDevice does not support asynchronous readback error in Shared AR & Plane Tracking guide

  • Issue category: ARDK Documentation / Networking
  • Device type & OS version: Android 12 / POCO X3 Pro
  • Host machine & OS version: Windows 10
  • Issue Environment : Unity Remote / Unity Mock / On Device
  • ARDK version: 2.0.0
  • Unity version: 2020.3.32f1

Hi there,

I’m having issues with the Shared AR Session & Plane Tracking.

I’m setting up the AR Session Manager’s and Network Session Manager’s Runtime Environment option to Mock as per this post in both the AR Session Manager and Network Session Manager.

I made sure the Use with AR Networking Session is checked in both manager.
When I run the app, I get a “This GfxDevice does not support asynchronous readback”.

As a note, the LowLevelNetworking Scene and the Basic guide are working fine on my phone.

What am I mising?

Thanks for your help.

Hello Hanaë,

Is this occurring within Unity or when built to device? One thing to check are the Graphics API Settings for Windows, specifically, that Vulkan has been removed. These can be found In Unity 2020.3 through:

  • Edit > Project Settings > Player
  • Other Settings > Rendering > un-check the box for Auto Graphics API for Windows to show the list of available Graphics API for Windows.
  • Remove Vulkan

Please let me know if this helps. If the issue persists, please copy/paste your console logs and any helpful screenshots in your response.

Hello Erik,

Thanks for the reply.

This error is showing in loop in the Android logcat when building and running on the Android device.

After checking, Vulkan is removed and I did uncheck the box.
This my settings:
image

Is there other options I should look into?

Thanks.
Hanaë