Unable to Import ARDK on M1 Based MacBook Pro

When importing the developer kit into Unity on my M1 based MacBook Pro on 2 different unity versions unity crashes every single time and no longer allows me to open the project.

Not sure if there is a unity Log I can send? can’t seem to find one in the folder.

Include the following details while filing a bug report (edit as applicable):

  • Issue category: Developer Tools
  • Device type & OS version: N/A
  • Host machine & OS version: Mac Monterey 12.0.1
  • Issue Environment : Unity Remote / Unity Mock / On Device / Dev Portal
  • Xcode version:
  • ARDK version: 1.0.1
  • Unity version: 2020.3.6 and 2021.1.18

Bug reproduction steps:

Open a fresh Unity project (this can be based on any of the templates) import the ARDK, Unity will crash.


Hello Robert, thank you for submitting your question here. I will take a look at your repro steps and reach out to the engineering team for a solution to your problem.

1 Like

Amazing thank you very much, Excited to be a part of the Lightship journey I can’t wait to get developing and shaping the AR Future

1 Like

Unfortunately, ARDK is not supported by certain Mac models with Apple Silicon processors (‘M1 chips’) as ARDK requires Unity 2019.4 LTS version which is also incompatible with Apple Silicon. The Niantic team is aware of this issue and is working to support this in future versions.

1 Like

Is there a bug system or other means of following along with this known issue? I also primarily use an M1 mac, and this issue more or less means there’s zero prototyping I can do until this issue is resolved and released.

Same on my side. MacBookPro M1 16GB. It says first some scripts need to be upgraded then crashes. Whats the Unity Version meant to be used with the ARDK? Thanks!

1 Like

Unity 2019.4 LTS, tried on a range of unity versions and they all appear to do the same unfortunately. us Apple Silicon users will just have a wait I guess :frowning:

1 Like

I want to know this also, if i could follow the bug so I know when the fix is realeased thats super useful

you did 1 better than me, I for some reason chose the 8GB, worst decision ever…

Its a real pitty with the M1 … especially with the 64gb version im waiting for. . without this bug fix youre missing out on a great leap in hardware tech…

1 Like

exactly, I actively user ARCore and ARKit so hopefully its not too hard of a fix

In case it counts, another M1 user here :wave: I was really hoping to test something this week :pensive:

M1 user here and if you are smart this is the MAC to get. Let’s hope Niantic pushes this to the top of the list.

1 Like

Yeah I think this is a huge issue that could be solved by Niantic team making the ARKIT compatible with Unity 2020.

Come on guys you can’t make such a big announcement and have most of the current iOS developpers left out like that, it’s just mean :wink:

1 Like

Any kind of ETA would be very helpful too

One more M1 user here, would love to be able to follow this bug as well if possible :grinning_face_with_smiling_eyes:

But actually Unity 2019.4 is supported on M1 Mac and I have been using that for many projects.

Does the ARDK work for you in that Unity version out of interest? Or do you get an error too of some kind?

I would suggest Niantic to take this as a critical blocker issue, hey it’s almost 2022, who’s going to buy Intel mac today?

We heard you! Here is a work around that our awesome engineer @Ben_Lau has come up with for the current issue. Please look for detailed instructions here .

1 Like