While running app on Phone, camera is of lower quality than expected

Real-time Mapping-Depth / ARDK Documentation
Android: version 11
On Device / Dev Portal
ARDK version: v1.3.0
Unity version: 2020.3.32f1

Description of the issue:

I’ve completed a few of the tutorials like GettingStarted, Placement, and Occlusions and I noticed that when running the apk on my phone the camera quality has dropped from what I see if I run the native camera app, or any other app that uses the camera. I also have noticed that it doesn’t seem to focus or clarify the view at all. I imagine I am missing something in my initial setup or perhaps some kind of positioning/scaling mistake, but I’m not even certain where to start.

I’ve attached two images of the same door. The first is from my phone’s camera and the second from the tutorial apk.

I’m fairly new to all of this, but I appreciate the chance to learn. Thank you in advance.


Hey Alexander,

I have a few requests and questions for you…

  • First could you tell us a bit more about the hardware you are using? Specifically the make and model of your phone?
  • If you think that running example scenes is the culprit for the drop in performance then try running scenes that don’t require much, i.e. the meshing example
  • If that does not work could you please show me what your scripts look like that you are using to access the ARDK features. If you could screenshot them or print them out in a text file that I can download that would be a great way to start. If you are not comfortable with that you can also email myself at jasonrose@lightship.dev with your scripts. It is the first place I would troubleshoot if something is not looking correct.

Jason thanks for the reply!

  • I am using an LG Wing. I’ve made a few Image tracking Unity AR apps using Vuforia and EasyAR without any noticeable loss in camera quality, while maintaining autofocus.

  • I’ll try the meshing example tomorrow and report back.

  • Which scripts would you want me to send your way and how? My lack of knowledge beyond wysiwyg options and following videos is unfortunately vast, but so is my interest to learn.

I can say that I’ve only added the current downloads from the Lightship documentation I found on the site (ardk-1.3.0., ardk-examples-1.3.0, ardk-mock-env-1.3.0) and followed the video tutorials on the site click for click thus far. I’ll gladly share any info you’d like with the forum in the hopes that it helps someone else down the line. Thank you so much for your time.

Hey Alexander,

Here are some follow-up questions:

  • When you are building for Android, did you follow the steps for setting things up in Unity: Building for Android It helps to go back over this part of the documentation just to double check that you are constructing your builds for android correctly.
  • As far as the scripts are concerned, for now let’s start with just a screenshot of where you placed them. I have included a screenshot of my camera for your reference. I have added all my scripts to the main camera.


  • I did follow the guide “Building for Android” and double-checked it when I noticed the camera concern. The builds are deploying and functioning as intended except for the image quality.

  • I’ve attached the screenshot of my script placement after completing the meshing tutorial (which worked though with the same camera concern)

  • Tomorrow I am hoping to borrow someone else’s device to have another point of testing.


Hi @Alchaun , apologies for the late reply, but I was following up on this question with one of our engineers and we were wondering about this part:

Did you happen to have Is Auto Focus Enabled in your ARSessionManager when you noticed this? If not, enabling/checking that box should help with the focus issue, at least. Note that this is also possible to set in code.

ARSessionManager Auto Focus

In regard to the camera feed itself being lower resolution, I’m currently looking into this and am seeing something similar to what you’ve mentioned. I’m trying a few things now to see if this can be adjusted or mitigated, and will hopefully be able to follow up with more information once that becomes available. Thanks!

1 Like

I tried running the app with and without the autofocus enabled button with similar results. I didn’t notice a change, but with the grainy resolution perhaps it is too subtle to notice. Thank you for checking back in.

I have the same problem, did you find a solution?