Casting shadows on the ground plane

Include the following details (edit as applicable):

  • Issue category: Contextual Awareness
  • Device type & OS version: iOS
  • Host machine & OS version: Mac M1
  • Issue Environment : On Device

Description of the issue:

Hi everyone, I am trying to cast shadows from AR objects that I spawn. I am curious to know whether there’s any possibility of casting a shadow on AR Mesh (invisible mesh) created by the ARDK. My goal is to have the shadow on other AR objects and the real-world plane. (in the below example, I like to see my shadow on the floor as well).

I have enabled “Light Estimation” on ARDK also.

Your suggestions are much appreciated. Thank you.

PS: Thank you so much @Dylan_Smit . It worked. I had to switch to URP and added the custom shader mentioned in this video. I really hope the Lightship team will give us in-built support for shadows to work seamlessly with occlusions.

Thanks again. This is solved now!

Curious as well.

1 Like

Follow this guide. Only 1 shadow cascade and no softshadows however, but it does work.
Doesn’t play nice with occlusion sadly, until they add this: Exclude mesh from Depth Occlusion - #4 by Dylan_Smit

This topic was automatically closed 2 hours after the last reply. New replies are no longer allowed.