Mesh cleared when ARMeshManager is disabled

Include the following details while filing a bug report (edit as applicable):

  • Issue category: Real-time Mapping-Depth
  • Device type & OS version: Android 9
  • Host machine & OS version: Windows 10
  • Issue Environment : On Device
  • ARDK version: 1.3.0
  • Unity version: 2020.3 LTS

Bug reproduction steps:

  • Set ARSessionManager.runOptions to “None”.
  • Enable the ARMeshManager and create a simple mesh.
  • Disable the ARMeshManager.
  • Enable the ARMeshManager again - the previous mesh is removed and the entire meshing process is restarted. I expected this to only happen if “Remove Existing Mesh” is set in the ARSessionManager. Also, the MeshBlocksCleared event is not raised.

Hi Kareem, use the Mesh Saver documentation to solve your problem. There is more information on saving files in this documentation as well. Let me know if you have more questions. Thanks.