Meshing not working

  • Issue category: Real-time Mapping-Depth
  • Device type & OS version: Android 9,10
  • Host machine & OS version: Windows
  • Issue Environment : On Device
  • ARDK version: 2.0.0
  • Unity version: 2020.3.30f1

Description of the issue: The meshes are not getting generated when I build the application on my device. I have followed all the steps that were mentioned in the documentation:

  1. Adding the AR Mesh
  2. Making sure the Mesh Prefab is set.
  3. Making sure the Mesh Prefab has a mesh collider, mesh renderer(with material set) and mesh filter
  4. Adding the Depth Manager to the AR Scene Camera and setting Occlusion to one.

I have tried it on two devices (Samsung Tab S3 and Samsung Galaxy Note 9) and none of those device generates the meshes . I’m not sure what the issue is here .

The first thing I do when the implementation in my app doesn’t work, is that I go to the examples. I check the configuration and setup there and compare it with mine. It usually gives me a hint what I missed. I assume you have already tried the example in the ContextAwareness > Meshing folder.

Making sure the Mesh Prefab has a mesh collider, mesh renderer(with material set) and mesh filter
The mesh prefab in the example actually don’t have a mesh filter. You may try using that prefab from the example and see if it works with your app. Then compare the difference with your mesh that could probably give a hint where things went wrong.

Hey , thanks for your reply.

I directly build the example project to my device , but it still doesn´t work. Not sure what the problem is. And by mesh filter I meant that the mesh filter is attached with no filter selected just like in the example configuration.

Hello Rishab,

Could you send me a screenshot of your build settings? It would also be helpful to have screenshots of any error logs you may have. These will allow us to piece together what might be causing your mesh’s not to show up.