Mesh and Semantics example not working

Issue category: Semantic Segmentation / Real-time Mapping-Depth / Unity Example Package
Device type & OS version: Android 12, Samsung S20 FE
Host machine : Windows 10
Issue Environment : On Device
ARDK version: 2.0.0
Unity version : 2021.3.0f1

Description of the issue: Previously I used to work on ARDK v 1.3 and it worked perfectly fine. For new features, I upgraded to ARDK 2.0.0.

I created a new project yesterday, after required changes and adding tags in Android Manifest File I build the app. Meshing, Semantics & Depth Occulsion example projects were working as expected.

But today, when I again tried to build the app. It was built successfully without any warnings but when I open respective scenes they don’t work anymore.

Issues :
Meshing : scene gets stucked at “Loading Context Awareness”. It is not creating any mesh. Camera is working.
Meshing Semantics, Semantic Segmentation: scenes do not show any UI (toggle UI).
It was not showing any error in logcat aswell.
DepthOcculusion: When I untick and tick Toggle Occlusion CheckBox, app freezes.

So

  1. I created a new project again.
  2. Imported ardk.unitypackage 2.0.0 and ardk-examples.unitypackage 2.0.0.
  3. Did necessary changes in PlayerSettings, Added Authkey.
  4. Added required scenes in build.
  5. Built the app for my device.

It is still not working and I am facing the same issues that I mentioned earlier.
I have no idea where am I wrong because the application I built yesterday is still working as required on my device.
In the previously installed app Meshing and SemanticsSegmantion scenes are working as expected, the mesh is created runtime & UI is also visible in SemanticSengmantation yet they fail to work in the new app.

PlaneAnchors scene is working as expected in both of the builds.

Any idea where I might be going wrong?

Just to mention Unity asked me to update some scripts when I first imported ardk.unitypackage v 2.0.0 So I gave it the permission to update them automatically.

Hello Rohan,

Please confirm a few things here,

  • Are you able to successfully compile and run this in unity or are you receiving any error messages in the editor?
  • How did you update your project to 2.0? Did you delete all your old 1.3 files? If not this might be causing the issue.

To upgrade and get everything to work properly, you must delete the ARDK folder, the ARDKExamples folder, the ARDKMockEnvironments folder, and the MockMeshes folder also, make sure you have imported all the packages for ARDK 2.0 Ver. from your Lightship dashboard under Sign in – Niantic Lightship.

Also, could you send us any screenshots of the errors you are receiving so we can take a look at them? Either a screenshot or an error log would be helpful.

.