Black Screen on Android

  • Issue category: ARDK Documentation
  • Device type & OS version: Android 12
  • Host machine & OS version: Windows 10
  • Issue Environment : On Device
  • ARDK version: 2.0.0
  • Unity version: 2021.3.3f1 (also tried with 2020.3.35f1)

Description of the issue:
I saw the five topics related to my issues. I have tried all of those and did not help me with my problem. I also want to say that I tried and built the app targeted to Android 12 and Android 8, with their respective configuration. I also tried the project with Unity 2020.3.35f1 and got the same result. The following are my configurations:


In addition I also tried lowering the Minimum API Level to 6. When I targeted level 30, I added the queries tag in my AndroidManifest. The app asked for access to the camera the first time I ran it. In between builds, I always uninstalled the app and reinstall it to test a new configuration. I also checked that my app has the correct permission. I also manually added access to the mic and location on each install.

I am able to build the same project to iOS and can see my sample app running on an iPhone.

What else am I missing on my Android build?

Do you get any information in the logcat?

This is all I got…

Hmm, there should be more actually. Can you filter for the tags ARDK and/or Unity?

I don’t know if this is related, but I upgraded to 2.0.0 and I’m starting to get a java ARCore result.length error message. This is with my Galaxy S9. It’s as if the device is not recognized as an ARCore device even though it worked earlier versions of ARDK.

Filtering with “ARDK” or “Unity” gives me nothing.

Unity has an Android Logcat package. Try adding that and keep the phone connected via USB Android Logcat | Android Logcat | 1.3.2 (

I also ran into strange problems since upgraded to 2.0.0…
results.length could also be somehow related with the ARCore’s HitResult, just from the naming :thinking:
Do you maybe have some more context (when it occurs or exact line of the error or so)?

@von Oh, just noticed, that you have also have set Minimum API Level to 29. Could you try 24 (Android 7, Nougat) instead? I remember this is recommended somewhere in the docs.

1 Like

Oh wow!! I missed it by two versions. So I tried this with Marshmallow (level 23), as I was testing with an old phone and Android 10 and it did not work. The following are what I tried in all:

Min API Level: Android 6.0
Target API Level: Any Level
Status: FAILED

Min API Level: Android 10.0
Target API Level: Android 10.0 and Android 11.0
Status: FAILED

Min API Level: Android 11.0
Target API Level: Android 10.0, Android 11.0, 31 and 32
Status: FAILED

Min API Level: Android 7.0
Target API Level: Android 10.0
Status: FAILED

Min API Level: Android 7.0
Target API Level: Android 11.0

Thanks a lot for your help @BBIT-Solutions !


This topic was automatically closed 2 hours after the last reply. New replies are no longer allowed.

Hello Voltaire,

I’m glad to see that you were able to get this issue resolved. Would you mind sharing the brand and model of device you were building your project to? We’re in the process of looking into a few other reports of black screens and sharing this information would really help.