Broken Game View, only works once when restarting unity

Include the following details (edit as applicable):

  • Issue category: ARDK Virtual Studio Tools
  • Host machine & OS version: Mac M1 Ventura
  • Issue Environment : Unity Remote / Unity Mock
  • Xcode version:
  • ARDK version: 2.3.1
  • Unity version: 2021.3.16f1

Description of the issue:
My Game-View does not work properly. It only works once when I restart Unity, then the Screen turns black. Have no idea why this happens, everything worked fine until now.

I’ve been testing a bit around and it is really weird. After hitting play for the second time, Mock meshes do work and I also see the game objects + UI. But I cannot move the camera (works in first play) and the environment is gone…

I’ve been able to narrow the issue down a bit more. I tried to reimport the Scene Manger of the ARDK but that does not have any effect seemingly.

As far as I am concerned there is an issue with the background removal of the AR Camera. Weirdly enough, as soon as I change anything that triggers Unity to reload the assemblies of the scene, suddenly all seems to work fine. However it appears like the camera jumps a few inches forward.

Maybe someone has a better solution than constantly changing the script :smiley: ?

Update 2: I think I found the issue.

I was trying to speed up Unity’s performance of reloading script assemblies. In the Unity settings and player settings I changed the options

“Script changes while playing” (Unity preferences)
and “Enter PlayMode options”. (Player settings)

If these are set back to default the error disappears

Hi Tobias, glad to see you were able to track this one down. We’ll point other users to this fix if they ever encounter a similar problem